HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   cannot access ispconfig web interface (http://www.howtoforge.com/forums/showthread.php?t=14429)

spekkio 1st August 2007 22:17

cannot access ispconfig web interface
 
So heres were i am, ive set up a functioning feisty fawn box according to this guide
http://howtoforge.org/perfect_setup_ubuntu704
and i then installed ispconfig according to this
http://www.ispconfig.org/manual_installation.htm
it all works fine, but i did this on my LAN and the ip the server got was 192.168.0.25. I then moved this server to another ip address, but it to had another router and i made sure it kept the same LAN ip of 192.168.0.25. I then went into ispconfig and under server settings changed the host and domain to www.example.com. Now for some reason i cant access the web interface of ispconfig outside of the LAN, i try https://www.example.com:81, and even the IP address and it still doesn't let me in. What it does end up doing is i get a error message saying. "www.example.com has sent an incorrect or unexpected message. error code -12263" but if i try changing the adress to http, instead of https, i get a directory listing "Index of /" so i know somethings there. Anyway any help would be appreciated on how i can access ispconfig from outside the LAN.

edge 1st August 2007 23:08

Do a search for 12263 on this forum, and you might find a fix.

spekkio 1st August 2007 23:55

ive gone through all the threads on that error code and im not finding something that will help, at best i think its just some ssl error. Anyone have any suggestions?

till 2nd August 2007 09:31

Please try to access your server with http:// and not https://.

spekkio 2nd August 2007 21:24

When i use http://server.example.com:81 i get a directory listing of "Index of /"
so somethings still not right, i just want to be able to access the ispconfig web interface from outside the LAN its on. I have a dns entry for the server so when i ping servername.example.com it resolves to the WAN IP. In ispconfig ive set the
hostname to servername
domain to example.com
ip address to LAN ip

so shouldnt i be able to put in https://servername.example.com:81 and get to the ispconfig web interface? All the ports on the router are forwarded properly and im considering taking the router out of the picture and just using the wan ip.

till 3rd August 2007 09:32

Are you able to access the ISPConfig interface from within your lan?

spekkio 3rd August 2007 17:47

Yep, from within the LAN it works great, using https://192.168.0.25:81.

spekkio 3rd August 2007 19:25

Well i figured out what i did wrong, when installing ispconfig i ended up encrypting the 2 rsa certs that you make with a pass phrase which is not what your supposed to do otherwise the ispconfig-apache doesnt start up properly on the system. It waits for you to enter the pass phrase :( So thats why i couldnt never access it from outside the lan.

Thanks edge and till for all the help though.

gillesdevals 16th December 2007 01:15

Same problem - but don't understand
 
I have the same problem, can't access to webmail, error in return : 12263.

I don't understand all the post regarding SSL Certificate.

Example of the error : https://www.devals.net:81/webmail


Is it possible to solve this problem simply ? with a detailed "howto"

I installed Debian 4.0 with ISPconfig 2.2.18


Thanks in advance for your help.

Gilles


All times are GMT +2. The time now is 10:50.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.