HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   New user directory location (http://www.howtoforge.com/forums/showthread.php?t=14331)

xyanide 28th July 2007 21:00

New user directory location
 
Hi there,

I`ve got a question about the location of the users.

My information:
Fedora 7 (incl all updates) Perfect server
ISPConfig 2.2.12 (latest)

Everything works, ftp / mysql.

But the problem is can`t find the location of new users, I`ve read the faq and this forum but couldn`t find a solution.

I`ve also tried this: http://www.howtoforge.com/faq/14_43_en.html but that doesn`t work for me, it just shows a page not found.

And the other question is: where are the users documents / webfiles saved (which directory)?.


Thanks in advance!

- Xyanide

edge 28th July 2007 23:31

Did you try
Code:

www.yourdomain.com/~webNR_name
The place the users (not admin) files are located in is: /var/www/webNR/users/wenNR_user
(and / or /var/www/domainname/users/webNR_user )

xyanide 29th July 2007 00:02

Quote:

Originally Posted by edge
Did you try
Code:

www.yourdomain.com/~webNR_name
The place the users (not admin) files are located in is: /var/www/webNR/users/wenNR_user
(and / or /var/www/domainname/users/webNR_user )

Yes i have, i`m now looking in the www directory and it indeed shows web1_xxxx web2_xxxx web3_xxxx, but when I try to connect to those accounts (ipadress/~web3_xxxx) it doesn`t work.

(right now i`m only using this installation local for testing purposes).

- Xyanide

edge 29th July 2007 10:52

ipadress/~web3_xxxx will not work.

An option would be to add the IP and domain to the hosts file of the PC that you are using to access the server with.

This way you are "forcing" the PC to go to that IP when your try to access the domain.

The location of the hosts file in Windows is c:\windows\system32\drivers\etc
When you do it this way, make sure that you restart your browser, to make it read the new hosts file.

xyanide 29th July 2007 15:45

Ok, i`ve now created the following domain name: http://xyanide.exs (shows the shared ip adress page).

But when i try to connect to the page now: http://xyanide.exs/~web3_xxx it shows a page not found.


- Xyanide

edge 29th July 2007 16:01

Did you add the needed data to the the hosts file of the PC that you are using to access the domain?

Example shown below is for a Windows system.
Code:

IP.OF.SERVER  xyanide.exs
IP.OF.SERVER  www.xyanide.exs

Make sure that you set the IP.OF.SERVER to the LAN IP of the server that ISPconfig is using.

xyanide 29th July 2007 16:07

Yes i have, and when I go to www.xyanide.exs / http://xyanide.exs it shows the "Shared IP" website of ispconfig. But when i try www.xyanide.exs/~web3_xyanide it shows a "page not found".

Maybe i`ve got to change something in ISP config?

If you want i can give you my ipaddress and the standard login data for my ISPConfig installation by pm? (so you can have a look at it).


- Xyanide

edge 29th July 2007 19:25

What IP are you seeing (in ISPconfig) under Management > Settings > IP Address ?
And ISPmanagement > 'The-domain-that-you-created' > IP Address ?

Both should be the same, and they should be your LAN IP when you are behind a router.

re: If you want i can give you my ipaddress and the standard login data for my ISPConfig installation by pm? (so you can have a look at it).

Sorry. Normally I would help you with this, but at the moment I really do not have time.

xyanide 31st July 2007 14:07

Yes, they both show my lan ip (static: 10.0.0.157).


- Xyanide

edge 31st July 2007 14:39

You got me on this one.

You have added to the PC's hosts file (the one that you are using to access ISPconfig with)
Code:

10.0.0.157  xyanide.exs
10.0.0.157  www.xyanide.exs

When you try http://www.xyanide.exs or http://xyanide.exs , you are seeing the xyanide.exs site okay.

When you try to access the users page (with http://www.xyanide.exs/~web3_xyanide ) you get a page not found (404)

Maybe try adding /index.html or /index.htm, and see if this helps?

You should see (if you did not delete the user/web3_xyanide/web directory):
Quote:

Welcome to your website!

--------------------------------------------------------------------------------

This is the default index page for user web3_xyanide. This file may be deleted or overwritten without any difficulty. This is produced by the file index.html in the directory user/web3_xyanide/web.
For questions or problems please contact the server administrator
I do not have a server on my LAN, so I can not test this, but theoratically the setup should work (I can not test it)

Maybe someother ISPconfig usere here can give it a test run?


All times are GMT +2. The time now is 09:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.