HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Update Manager on ISPconfig (http://www.howtoforge.com/forums/showthread.php?t=1412)

techngo 27th November 2005 04:26

Update Manager on ISPconfig
 
I tried to install the phpmyadmin update and I keep getting a php install error on line 40
tmp_dir_error.
I am runing Fedora 4 on a pIII box.
used the perfect setup guide and got ispconfig installed and runing.

I have tried using the url and downloading the package to my home folder and point to it using upload.

Any ideas would be helpful. :eek:
I am new to this

till 27th November 2005 09:53

What is the exact error message you get?

techngo 27th November 2005 16:36

ispconfig update manager
 
Warning: mkdir() [function.mkdir]: No such file or directory in /home/admispconfig/ispconfig/web/admin/update/install.php on line 40
The following error occurred:


tmp_dir_error

Thanks

techngo 27th November 2005 22:28

ispconfig update manager
 
:) I figured it out. I needed to creat a temp directory inside /home/admispconfig/ispconfig/web/admin/update then I had to give the ispadmin write priv.

thanks for your reply though

:o

till 28th November 2005 10:52

To create thi directory helped you to solve this problem temporaily, but its not a resolution, because the correct temp directory is here: /home/admispconfig/ispconfig/temp

Hva e you changed someting in the ISPConfig php.ini or in the config.inc.php file of ISPConfig?

techngo 3rd December 2005 21:12

Update manager
 
Of course you were right I had the path wrong on the temp directory.
I was guessing on the locaction of the temp directory. the error message was not very specific.

Also needed to put the right privlidges on the temp directory.
How come the temp directory wasn't created during the ispconfig install?

Thanks

:)

till 4th December 2005 12:45

This directory: /home/admispconfig/ispconfig/temp was not created during install?

techngo 4th December 2005 16:01

Update Manager
 
No it did not :confused: I know this for a fact as I just completed the install for the second time. Both times were on a clean install, I could not run the update manager until I added the temp directory and added permissions to the folder for adminispconfig.

Thanks

bve32k 12th November 2006 17:15

I am bring this thread back from the dead!

I am having the same problem. I installed it 2 times now and that temp folder is still not being created so I created it manually. Now I am lost on what I have to do after that..Any help would be appreciated!

Thanks, Ken

Edit: Forgot to add I am using Fedora 6.

till 13th November 2006 10:17

Please run:

Quote:

chown admispconfig /home/admispconfig/ispconfig/temp


All times are GMT +2. The time now is 02:47.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.