HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   how to enable Mod Rewrite (http://www.howtoforge.com/forums/showthread.php?t=14114)

AngelDrago 17th July 2007 20:34

how to enable Mod Rewrite
 
How do i enable Mod Rewrite in ISPconfig with Debian Etch...

falko 18th July 2007 18:57

Just run
Code:

a2enmod rewrite
/etc/init.d/apache2 restart


AngelDrago 18th July 2007 20:38

Thank you Falko... but for some reason my user friendly page will not show up as soon as i include .htaccess to the web sites

bigger_travis 18th July 2007 23:08

i also wanted to know how to enable the mod_rewrite, this is a very simple way to install it

http://www.wallpaperama.com/disp-post10.html

falko 19th July 2007 15:05

Quote:

Originally Posted by AngelDrago
Thank you Falko... but for some reason my user friendly page will not show up as soon as i include .htaccess to the web sites

Any errors in Apache's error log?

AngelDrago 3rd August 2007 03:43

Hallo Falko,

here is the log...
[Thu Aug 02 20:40:09 2007] [alert] [client ]68.1.111.119 /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:09 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:10 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:10 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:11 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:11 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:11 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:11 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:11 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:11 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:11 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:11 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:11 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:11 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:12 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:12 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:14 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:14 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:15 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here
[Thu Aug 02 20:40:15 2007] [alert] [client 68.1.111.119] /var/www/web1/web/.htaccess: Options not allowed here

and here is my htaccess file Options All -Indexes
Options +FollowSymLinks
RewriteEngine On

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php

this should work but i do not understand why i'm getting 500 errors

Thank you for your help

falko 4th August 2007 11:13

Remove
Code:

Options +FollowSymLinks
from your .htaccess file and then add something like
Code:

<Directory /var/www/web1/web>
  Options +FollowSymLinks
</Directory>

to the Apache Directives field of web1 in ISPConfig.

AngelDrago 7th August 2007 21:49

Hi Falko, Thank you... but it did't worked what is a good test to see if htaccess actually workes???....

maybe one of you hat the same problem i have purchased SubDreamer and istalled just fine but as soon as i turn on Friendly URLs but with out the htaccess i'm getting only 404 page error's...

falko 8th August 2007 13:50

Any errors in Apache's error log?
What's in your .htaccess file now?

AngelDrago 10th August 2007 23:20

Hi Falko i know that mod_rewrite is working just fine i found a great script that shows if you have mod_rewrite on or off i really thing it's the way that htaccess workes and it makes me sick that i can not use one of the good future of the script that i'm using but that is o.k i guess... anyway Falko thank you very much for your help on this i really appriciated.


All times are GMT +2. The time now is 15:16.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.