HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   DNS zone file problems. (http://www.howtoforge.com/forums/showthread.php?t=13884)

tmdg 6th July 2007 01:52

DNS zone file problems.
 
Hi,

I'm running two ISPConfig systems both are on 2.2.14.

On server 1 everything seems fine. The zone files are in /var/named/chroot/var/named
On server 2 there are zone files in /var/named/chroot/var/named but if I add a new host the zone files don't change. If I add a new domain the zone files don't get created.

I'm sure server 2 used to work but I recently updated from 2.2.6 or may be 2.2.9.

I don't see any errors in the /var/log/messages nor do I see any errors /home/admispconfig/ispconfig/ispconfig.log

Does anyone have suggestion of were to look for the cause of the problem?

Regards,
Tom.

till 6th July 2007 13:13

Please have a look at the ispconfig.log logfile if you see any errors. Also make sure that /var/named/chroot/var/named is world readable.

tmdg 6th July 2007 17:51

Quote:

Originally Posted by till
Please have a look at the ispconfig.log logfile if you see any errors. Also make sure that /var/named/chroot/var/named is world readable.


As I siad in my post I don't see any errors in ispconfig.log

# pwd
/var/named/chroot/var
# ls -l
total 24
drwxrwxr-x 4 root named 4096 Jul 6 08:58 named
drwxrwxr-x 4 root named 4096 Mar 13 2003 run
drwxrwx--- 2 named named 4096 Mar 13 2003 tmp

and the zone files in /var/named/chroot/var/named are owned by named group named.

Regards,
Tom.

falko 6th July 2007 19:27

What's the output of
Code:

ls -la /root/ispconfig
?

tmdg 6th July 2007 21:40

]# ll -a /root/ispconfig/
total 104
drwxr-xr-x 9 root root 4096 Jul 6 19:30 .
drwxr-x--- 5 root root 4096 Jul 5 21:00 ..
-rwxr-xr-x 1 root root 33072 Jun 30 09:48 cronolog
-rwxr-xr-x 1 root root 9673 Jun 30 09:48 cronosplit
drwxr-xr-x 12 root root 4096 Jun 30 09:26 httpd
drwxr-xr-x 15 root root 4096 Jun 30 09:48 isp
-rw-r--r-- 1 root root 0 Jul 6 19:30 .ispconfig_lock
-rw-r--r-- 1 root root 8 Jul 6 19:30 .old_path_httpd_root
drwxr-xr-x 6 root root 4096 Jun 30 09:26 openssl
drwxr-xr-x 6 root root 4096 Jun 30 09:37 php
drwxr-xr-x 4 root root 4096 Jun 30 09:48 scripts
drwxr-xr-x 4 root root 4096 Jun 30 09:48 standard_cgis
drwxr-xr-x 2 root root 4096 Jun 30 09:48 sv
-rwx------ 1 root root 9389 Jun 30 09:48 uninstall

I'm gonna guess that the .ispcong_lock is the problem.

I removed it and bingo several of the zone files updated.

it's still not right as the lock reappears though.

tom.

till 7th July 2007 14:20

The lockfile must appear while the script is running. If it does not get removed after the end of the script run, then something caused the script to die, maybe a segfault.

tmdg 7th July 2007 15:14

Quote:

Originally Posted by till
The lockfile must appear while the script is running. If it does not get removed after the end of the script run, then something caused the script to die, maybe a segfault.

So I need to fix something then. :)

It's kind of sorted itself out now. If I use DNS manager to alter a zone file then the only thing that happens is named.conf gets screwed up.
But the lock file is lot left. Ir is removed.

Line 3 is changed to
directory "/home/admispconfig/ispconfig/web/multidoc/edit";
When it should read
directory "/var/named/chroot/var/named";

So named fails to start. I correct the file and the named starts but my zone file is still not updated.

Where do I look to work out why the named.conf is getting the wrong directory?

Regards,
Tom.

till 7th July 2007 16:58

Which linux distribution do you use?

Please redo the steps for the bind configuration from the perfect setup for your linux distribution to fix the permission problem. If the problem is fixed, ISPConfig will use the correct directory for your bind files when you set it under management > server > settings in ISPConfig.

tmdg 7th July 2007 18:42

Quote:

Originally Posted by till
Which linux distribution do you use?

Fedora Core 5.
Quote:

Originally Posted by till
ISPConfig will use the correct directory for your bind files when you set it under
management > server > settings in ISPConfig.

Thats is I think. Well it looks like it works now.

Regards,
Tom.


All times are GMT +2. The time now is 22:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.