HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   External Mail Server (http://www.howtoforge.com/forums/showthread.php?t=1377)

christopher 23rd November 2005 20:42

External Mail Server
 
Hi!

I have an ISPConfig installation running, which has worked well right off the bat.
It has been a little quirky to me - somewhat unintuitive.

For example, I have some domains that have external mail servers, hosted somewhere
in the world where I have no control of the administration.

So, I go ahead and use the "external mail server" option in the site's options, and
I create DNS records that work for the rest of world.

However, after creating DNS records that work and choosing the "external mail server"
option, the mail server (Postfix) still tries to deliver mail locally, instead of using the
MX record I made. This happens whenever the local Postfix mail server was used to
try to send the mail to a domain with an external mail server.

I see in /etc/postfix/local-host-names a list of domain names. If I remove the domain
from the file, the domain name just reappears.

What gives?

I am not sure what to do with ISPConfig to get the Postfix to work as intended.

Thanks for any help!

Chris

falko 23rd November 2005 21:14

Make sure that you also set your Co-Domains to "External Mailserver"! It's a difference if only www.example.com or also example.com is set to "External Mailserver".

christopher 24th November 2005 01:06

Thank You
 
Thank you, falko!
:)


All times are GMT +2. The time now is 11:50.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.