HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Question about routers? (http://www.howtoforge.com/forums/showthread.php?t=1358)

TacitCracker 22nd November 2005 10:50

Confused with my server
 
I have been working on setting up my website for a few days now and have hit quicksand. I want to run my own server from my pc that is running SuSe. I am struggling to publish my site to the web. I am using Apache; What do I need to do to view my site under my ip address and how can I connfigure Apache HTML Server to do this?

falko 22nd November 2005 12:46

You have to forward all needed ports (e.g. 21, 22, 25, 80, 110, 443, 143, 993, 995) from your router to your server.

The DNS records for your domain have to point to your router's public IP address, not your server's local IP address!

themachine 22nd November 2005 17:27

Also keep in mind, that if your network is NAT'd that the IP you use to connect to this server will be different inside and outside of your network.

For example, when you are inside the network... you need to connect to the server with the 192.168.x.z IP, but when you are outside you need to connect to whatever your public/external IP is.

When you are inside, you can not hit the external IP address... and the re-NAT and hit your internal server.


All times are GMT +2. The time now is 21:24.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.