HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Virtual Users and Domain with Postfix etc - Problems after updating postfix (http://www.howtoforge.com/forums/showthread.php?t=1353)

ryv 22nd November 2005 01:04

Virtual Users and Domain with Postfix etc - Problems after updating postfix
 
Hi Guys,
firstly let me say the tutorial was excellent. Probably one of the easiest to follow, but maybe a little light in terms of explanation of steps. Nevermind about that though.

I set my system up (Debian Sarge) as per the tutorial and then, as per security rules here, apt-get updated my os. It downloaded and installed a new version of postfix and then I started seeing these errors in my logs, and not receving any new mail:

Errors:

Nov 22 11:00:17 sentinel postfix/master[7168]: warning: process /usr/lib/postfix/virtual pid 7216 exit status 1
Nov 22 11:00:17 sentinel postfix/master[7168]: warning: /usr/lib/postfix/virtual: bad command startup -- throttling
Nov 22 11:01:17 sentinel postfix/virtual[7217]: fatal: mysql:/etc/postfix/mysql-virtual_mailboxes.cf: proxy map is not allowed for security sensitive data
Nov 22 11:01:18 sentinel postfix/master[7168]: warning: process /usr/lib/postfix/virtual pid 7217 exit status 1
Nov 22 11:01:18 sentinel postfix/master[7168]: warning: /usr/lib/postfix/virtual: bad command startup -- throttling

I'm not sure what this means and given my conf files look the same as the ones from the tutorial - I don't know where I've gone wrong either. Can anyone offer me some help?

Thanks,

ryv

falko 22nd November 2005 12:12

Can you tell me your current Postfix version? Run
Code:

postconf -d | grep mail_version
to find out.

ryv 22nd November 2005 21:28

Here is the results of that command:

sentinel:/etc/postfix# postconf -d | grep mail_version
mail_version = 2.1.5


Thanks

falko 22nd November 2005 22:41

Hm, that's ok...
Please remove all the "proxy:" strings from /etc/postfix/main.cf, e.g. change

Code:

virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
to

Code:

virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
and restart Postfix.

ryv 22nd November 2005 22:45

Falko,

I restarted postfix and got the following message:

Nov 23 06:26:44 sentinel postfix/virtual[26916]: fatal: mysql:/etc/postfix/mysql-virtual_mailboxes.cf: proxy map is not allowed for security sensitive data

I also note that the logs report:
Nov 23 06:26:45 sentinel postfix/master[7168]: warning: process /usr/lib/postfix/virtual pid 26916 exit status 1
Nov 23 06:26:45 sentinel postfix/master[7168]: warning: /usr/lib/postfix/virtual: bad command startup -- throttling

I've just had 40 odd emails arrive too. It doesn't appear to have stopped mail being delivered, but I'm still concerned about the error.

Thanks!

ryv

falko 22nd November 2005 22:56

Quote:

Nov 23 06:26:44 sentinel postfix/virtual[26916]: fatal: mysql:/etc/postfix/mysql-virtual_mailboxes.cf: proxy map is not allowed for security sensitive data
You have to remove "proxy:" from all lines in /etc/postfix/main.cf.

ryv 22nd November 2005 23:04

"proxy:" has been removed from all lines in /etc/postfix/main.cf. (and had been at the time of my last post).

The only remaining proxy is the proxy_read_maps line. Does this need to be changed in any way?

ryv 22nd November 2005 23:56

Actually, it's all working OK now. My syslog was a mess (but that's another story).

Thanks Falko for the great tutorial and the help.

ryv


All times are GMT +2. The time now is 00:38.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.