HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Character encoding within ISPConfig (http://www.howtoforge.com/forums/showthread.php?t=13491)

melwood 18th June 2007 14:05

Character encoding within ISPConfig
 
Hi,

there are a lot of post concerning character encoding, but they all seem to be about the "normal" apache webserver running on port 80.
I insatlled my server according the "perfect debian etch" Howto and after that installed ISPConfig. I added "AddDefaultCharset ISO-8859-1" and the "normal" site all work well now.
But I also have an character encoding problem within ISPConfig. All special characters like ,, ect. are mixed up.

The encodeing of the ISPConfig HTML-pages is set to ISO-8859-1.

Is it possible that the german translation files are utf-8 encoded?

melwood

Leszek 18th June 2007 18:03

Hi!
You should look for:
Code:

$go_info["theme"]["charset"] = "iso-8859-2";
in /home/admispconfig/ispconfig/lib/config.inc.php and change it to what You need.

melwood 18th June 2007 19:32

Quote:

Originally Posted by Leszek
Hi!
You should look for:
Code:

$go_info["theme"]["charset"] = "iso-8859-2";
in /home/admispconfig/ispconfig/lib/config.inc.php and change it to what You need.

It's set to "iso-8859-1" which should be fine for german "Umlaute"...

melwood

melwood 18th June 2007 21:33

More info about my problem:

When I switch the encoding within my browser manually to UTF-8 the special characters will be shown correctly.

But the encoding of the page is iso-8859-1:
HTML Code:

<title>ISPConfig Startseite</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

The strange thing is, that when I look at the html-source within the browser, the special chracters are also shown correctly.

melwood

till 19th June 2007 09:50

Quote:

Is it possible that the german translation files are utf-8 encoded?
No, they are all in Latin-1 and ISPConfig does not support UTF-8. I use ISPConfig also with german umlauts without having to change anything. Are the german locales installed on your server, e.g. the de@euro locale?

melwood 19th June 2007 10:04

Quote:

Originally Posted by till
No, they are all in Latin-1 and ISPConfig does not support UTF-8. I use ISPConfig also with german umlauts without having to change anything. Are the german locales installed on your server, e.g. the de@euro locale?

Sorry, but I don't know, how to check this and if they are not installed how to install them (debian etch). Can I do this with apt-get?

I know, people like me shouldn't run a dedicated server ;-)

melwood

till 19th June 2007 10:09

The command is:

dpkg-reconfigure locales

melwood 19th June 2007 10:29

Quote:

Originally Posted by till
The command is:

dpkg-reconfigure locales

Okay, the only locale installed was de_DE.UTF-8. I now installed
de_DE.ISO-8859-1 and de_DE.ISO-8859-15@euro and selected de_DE.ISO-8859-15@euro as default.

Everything works fine now except the "status"-tab when I login as admin. But it is possible that I screwd up the language file while trying to solve the problem myself ;-)

The only problem is, that I can't find the language file for this tab. Do you know in which lib-folder it is?

melwood

falko 19th June 2007 13:53

Quote:

Originally Posted by melwood
The only problem is, that I can't find the language file for this tab. Do you know in which lib-folder it is?

There's no language file for the Status tab. It just grabs the output of
Code:

df -h
on your shell and displays it.

melwood 19th June 2007 14:11

Quote:

Originally Posted by falko
There's no language file for the Status tab. It just grabs the output of
Code:

df -h
on your shell and displays it.

Thanks for your help. After installing the new locale, setting it to de_DE.ISO-8859-15@euro and restarting the server, now the text in the browser is in english. But when I issue the command on the console it is in german, strange...

melwood


All times are GMT +2. The time now is 20:05.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.