HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Postfix mail problem (http://www.howtoforge.com/forums/showthread.php?t=1345)

rytech 21st November 2005 17:35

Postfix mail problem
 
We have recently ran into a problem with our postfix server. I am running SuSE 9.3. When I try to telnet into our server, I get the message:

Quote:

Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.
I don't get the chance to login to the mail server. It was working, but now it's not. The mail logs list this:

Quote:

Nov 21 08:20:30 srv1 postfix/smtpd[3668]: fatal: no SASL authentication mechanisms
Nov 21 08:20:31 srv1 postfix/master[3544]: warning: process /usr/lib/postfix/smtpd pid 3668 exit status 1
Nov 21 08:20:31 srv1 postfix/master[3544]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Listing of main.cf file
Quote:

readme_directory = /usr/share/doc/packages/postfix/README_FILES
inet_protocols = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
#virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = srv1.$mydomain
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
#mydestination = $myhostname, srv1$mydomain
defer_transports =
disable_dns_lookups = no
relayhost =
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtp_sasl_auth_enable = yes
smtpd_sasl_auth_enable = yes
smtpd_use_tls = yes
smtp_use_tls = yes
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 50000000
mydomain = xxx.ca
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names
If anyone could point me in the right direction, that would be greatly appreciated. If you require more information, please let me know.

rytech 21st November 2005 17:44

Ok solved it!! Hehe... In the file /usr/lib/sasl2/smtpd.conf it should list:

Quote:

pwcheck_method: saslauthd
mech_list: login plain
Mine for some reason was set to PAM.

Just in case someone else comes across this problem.


All times are GMT +2. The time now is 17:28.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.