HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   mydomain.com fetches to my router's web interface (http://www.howtoforge.com/forums/showthread.php?t=13387)

kreya 13th June 2007 12:34

mydomain.com fetches to my router's web interface
 
hi,
when i try accesing mydomain.com it gets me to my router web interface.

i've created A record, MX record, CNAME record for mydomain.com in my domain registrar's cpanel pointing mydomain.com to my static IP which is assigned to my router.

i installed ispconfig using IP instead of mydomain.com cos' my changes weren't updated. now i can ping www.mydomain.com and i get reply from my router.
I use my ISP DNS servers.

what i am trying to accomplish is
www.mydomain.com should get me to my website instead of ispconfig interface

how could this be done?

Hans 13th June 2007 13:17

Did you change the ISPConfig server settings already within ISPConfig under Management > Server > Settings > Server ?

Change the domainname within your INTERNAL IP-address (not your external IP-address).
Change the Hostname within: www

Afterwards, save your settings.

kreya 13th June 2007 13:46

the config is
ispconfig -- management -- server -- settings --
Hostname: www
Domain: mydomain.com
IP Address: 192.168.0.3

saved and restarted

but still accessing www.mydomain.com shows my router's web interface

Hans 13th June 2007 14:02

Oeps, i made a mistake:


If for example the output of

hostname -f

is: server1.example.com

you need to set the hostname within ISPConfig to server1 in stead of www.

kreya 13th June 2007 14:25

made the changes.
but still http://server1.mydomain.com.com fetches router's web interface.

i've not made any changes in host file in windows cos' www.mydomain.com should work no matter where i access from.

Hans 13th June 2007 16:13

If you try to access your site within your LAN, maybe you need to configure your Windows workstation so that it also uses your own DNS-server on your ISPConfig server.


All times are GMT +2. The time now is 17:40.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.