HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   SMTP relay trouble (http://www.howtoforge.com/forums/showthread.php?t=13313)

DVS 11th June 2007 00:17

SMTP relay trouble
 
Hey guys.

I've recently re-installed and updated my domains with two MyDNSConfig servers as DNS servers and one ISPConfig server for my domain hosting.

Since this new installation (I guess - cause I've only picked the problem up now - about a week later) I can't relay my mail via my domains.

It is as if it catches the mail - but for some unknown reason doesn't send it on. BTW, receiving mail works 100%. O, and when I send mail to and from domains hosted by my servers it works 100% as well.

This is what may Mail log said for today:
Code:

-----------------------------------------------------------------------
Jun 10 23:50:31 server1 postfix/anvil[31690]: statistics: max cache size 1 at Jun 10 23:46:14
Jun 10 23:52:23 server1 postfix/qmgr[10144]: D06F9220E15: from=<address@mydomain.net>, size=1893, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: D1AFE220D83: from=<address@mydomain.net>, size=1879, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: 99900220DA0: from=<address@mydomain.net>, size=1879, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: 9B076220DC8: from=<address@mydomain.net>, size=1887, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: 279E1220E14: from=<address@mydomain.net>, size=1887, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: 54463220E17: from=<address@mydomain.net>, size=1897, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: C02EE220D9E: from=<address@mydomain.net>, size=1891, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: 8470D220D95: from=<address@mydomain.net>, size=1879, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: 79A86220E19: from=<address@mydomain.net>, size=1879, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: ADC5622039A: from=<address@mydomain.net>, size=1861, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: AEACD220D94: from=<address@mydomain.net>, size=1893, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: 32557220EF9: from=<www-data@server1.mydomain.net>, size=768, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: 101C2220D9B: from=<address@mydomain.net>, size=1887, nrcpt=1 (queue active)
Jun 10 23:52:23 server1 postfix/qmgr[10144]: 1C911220D76: from=<address@mydomain.net>, size=1887, nrcpt=1 (queue active)
Jun 10 23:52:43 server1 postfix/smtp[31766]: D1AFE220D83: to=<address1@somedomain.net>, relay=none, delay=82322, delays=82302/0.02/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=somedomain.net type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/smtp[31765]: D06F9220E15: to=<address2@somedomain.net>, relay=none, delay=255110, delays=255090/0.02/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=somedomain.net type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/smtp[31767]: 99900220DA0: to=<address3@somedomain.net>, relay=none, delay=82263, delays=82243/0.03/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=somedomain.net type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/smtp[31768]: 9B076220DC8: to=<address4@somedomain.net>, relay=none, delay=255133, delays=255113/0.03/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=somedomain.net type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/smtp[31769]: 279E1220E14: to=<address5@somedomain.net>, relay=none, delay=255121, delays=255101/0.04/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=somedomain.net type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/qmgr[10144]: 54463220E17: to=<address6@somedomain.net>, relay=none, delay=255086, delays=255066/20/0/0, dsn=4.4.3, status=deferred (delivery temporarily suspended: Host or domain name not found. Name service error for name=somedomain.net type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/smtp[31773]: 32557220EF9: to=<address7@gmail.com>, relay=none, delay=12097, delays=12077/0.07/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=gmail.com type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/smtp[31770]: C02EE220D9E: to=<user@nomail.co.za>, relay=none, delay=82275, delays=82255/0.05/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=nomail.co.za type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/smtp[31771]: 8470D220D95: to=<address8@gmail.com>, relay=none, delay=82298, delays=82278/0.06/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=gmail.com type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/smtp[31772]: ADC5622039A: to=<user@nomail.co.za>, relay=none, delay=82345, delays=82325/0.06/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=nomail.co.za type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/qmgr[10144]: 79A86220E19: to=<address9@somedomain.net>, relay=none, delay=255063, delays=255043/20/0/0, dsn=4.4.3, status=deferred (delivery temporarily suspended: Host or domain name not found. Name service error for name=somedomain.net type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/qmgr[10144]: AEACD220D94: to=<address10@somedomain.net>, relay=none, delay=82310, delays=82290/20/0/0, dsn=4.4.3, status=deferred (delivery temporarily suspended: Host or domain name not found. Name service error for name=somedomain.net type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/qmgr[10144]: 101C2220D9B: to=<address11@somedomain.net>, relay=none, delay=82287, delays=82266/20/0/0, dsn=4.4.3, status=deferred (delivery temporarily suspended: Host or domain name not found. Name service error for name=somedomain.net type=MX: Host not found, try again)
Jun 10 23:52:43 server1 postfix/qmgr[10144]: 1C911220D76: to=<address12@somedomain.net>, relay=none, delay=82333, delays=82313/20/0/0, dsn=4.4.3, status=deferred (delivery temporarily suspended: Host or domain name not found. Name service error for name=somedomain.net type=MX: Host not found, try again)
-----------------------------------------------------------------------

I'm guessing the "queue active" means that my server received the mail that needs to be relayed. And also that the "delivery temporarily suspended: Host or domain name not found" means that it can't find that specific domain that I'm trying to mail.
Now I know this domain exists (anybody know gmail...? yeah, it exists. and all the others the same) so what could it be?
Might it be that my hosting server is trying to use my DNS server that is only authoritative for the domains it is hosting, to try and find the domains I am trying to mail? Cause in effect, the DNS servers are the only changes I've made from my previous installation to this new "upgrade". (cant think why this would be a problem though...we installed bind so it shouldn't be a problem...should it?)

Anybody with an idea?? :eek:

till 11th June 2007 08:30

Please check that the dns servers in /etc/resolv.conf are working. Be aware that mydns is not able to reslolve external domains, so you will have to enter there a dns server that is capable of resolving external domains too.

DVS 11th June 2007 09:07

hey till
 
till we met again :p

hehe excuse me - coffe...need....to...drink........now

Thanks for the responce - I've checked the resolv.conf and remember setting it. The ip's entered work I'm certain (the rest of my network is using it as DNS's so I think that solves the issue).

My entries on my DNS servers look like this (Ubuintu 7.04):

nameserver 1.2.3.4
nameserver 5.6.7.8

and that is it. Nothing else. Is this ok? (except for the fake ip's)

Ok...so I just picked up that my resolv.conf on my ISPConfig server has completely bogus DNS IP's. Well, not completely bogu, but I don't think I should use the ISPConfig server IP there now should I... - this is probably the problem eh :cool:

I'll quickly put this to the test.

Oh, next time remind me to have coffe BEFORE I put my computer on :o

DVS 11th June 2007 09:56

Just to clear it
 
Just for closure - this solved my issues :)

Thanks till we meet again. ;)


All times are GMT +2. The time now is 12:19.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.