HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Desktop Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=13)
-   -   Fedora Core4 and HP printer file problem(hplip) (http://www.howtoforge.com/forums/showthread.php?t=1304)

horus9520 18th November 2005 09:33

Fedora Core4 and HP printer file problem(hplip)
 
Hi here,

I am a new corn to Linux. I just installed fedora core 4. Since I have a color LaserJet printer, I want to install the driver for it. So I download 'hplip-0.9.6' from hp.com. However, when I am doing the procedure as described in http://hpinkjet.sourceforge.net/install.php#HPLIP .
At step 2: Download and install the HP printing software
When I type 'make', it comes with the following error message

*********
/bin/sh ./libtool --mode=link --tag=CXX g++ -g -O2 -o hpiod hpiod.o channel.o device.o mlc.o system.o jddevice.o jetdirect.o udevice.o uppdevice.o ppdevice.o pp.o -lnetsnmp -lcrypto -lpthread
g++ -g -O2 -o hpiod hpiod.o channel.o device.o mlc.o system.o jddevice.o jetdirect.o udevice.o uppdevice.o ppdevice.o pp.o /usr/lib64/libnetsnmp.so -lcrypto -lpthread
make[1]: *** No rule to make target `COPYING', needed by `all-am'. Stop.
make[1]: Leaving directory `/home/***/Software2005Nov/hplip-0.9.6'
make: *** [all-recursive] Error 1
*********

Could anyone give a hint on what is wrong? Thanks a lot in advance!

falko 18th November 2005 11:22

Are you on a 64-bit system?

horus9520 18th November 2005 23:04

Quote:

Originally Posted by falko
Are you on a 64-bit system?

yes, the system is 'em64t'. hplip doesn't support that?

falko 19th November 2005 03:24

Does /usr/lib exist?
If not (only then!), I'd try to create a symlink:
Code:

ln -s /usr/lib64 /usr/lib
and install the HP software again.

horus9520 19th November 2005 22:16

Thank you!

/usr/lib64 exists. It contains libnetsnmp.so . The error message is

/bin/sh ./libtool --mode=link --tag=CXX g++ -g -O2 -o hpiod hpiod.o channel.o device.o mlc.o system.o jddevice.o jetdirect.o udevice.o uppdevice.o ppdevice.o pp.o -lnetsnmp -lcrypto -lpthread
g++ -g -O2 -o hpiod hpiod.o channel.o device.o mlc.o system.o jddevice.o jetdirect.o udevice.o uppdevice.o ppdevice.o pp.o /usr/lib64/libnetsnmp.so -lcrypto -lpthread
make[1]: *** No rule to make target `COPYING', needed by `all-am'. Stop.
make[1]: Leaving directory `/root/Software/hplip-0.9.6'
make: *** [all-recursive] Error 1

Are there any more hints? Thanks a lot!

falko 20th November 2005 02:31

But does /usr/lib exist? (not /usr/lib64...)

horus9520 20th November 2005 03:21

Quote:

Originally Posted by falko
But does /usr/lib exist? (not /usr/lib64...)

Yes. It does exist.

kyuso 25th December 2005 02:04

Quote:

Originally Posted by horus9520
Hi here,

I am a new corn to Linux. I just installed fedora core 4. Since I have a color LaserJet printer, I want to install the driver for it. So I download 'hplip-0.9.6' from hp.com. However, when I am doing the procedure as described in http://hpinkjet.sourceforge.net/install.php#HPLIP .
At step 2: Download and install the HP printing software
When I type 'make', it comes with the following error message

I finally had success with fedora core 4 and hplip 0.9.7+patched.

Be sure to get 0.9.7 and a patch (both from download site). extract and cd into the source,

patch -p0 < patchfile (or was that -p1?)
./configure --prefix=/usr
make clean; make; make install

I found make clean is a necessary step since some shared object files don't get generated.

One other thing to watch: /etc/init.d/hplip script does not start hpssd properly due to selinux.

Option 1: run hpssd manually from command line:

/usr/share/hplip/hpssd.py

Option 2: change hplip security type:

chcon -t bin_t /etc/init.d/hplip

I still can't make the script work during boot. Anyone finds a solution, please post. Something to do with selinux I guess.

Otherwise, I'm happy with network scan, print, and service info.

skog 10th January 2006 17:48

hpssd wasn't able to connect to hpiod.

I had to change line 140 in /etc/init.d/hplip from:

daemon ./hpssd.py

to:

daemon 'python ./hpssd.py'


no more problems.


All times are GMT +2. The time now is 01:24.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.