HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   Reseller can't login (http://www.howtoforge.com/forums/showthread.php?t=12776)

smartcall 17th May 2007 21:13

Reseller can't login
 
Hello to all,

I have this strange problem:
One of the resellers can't login to his account anymore. He used to be able to do that, but all the sudden he can't.
I changed his username and password, and the problem persists. I also tried to login with the new username and password, and ISPConfig rejects the credentials.
What could be wrong?

P.S. Maybe important: this guy has two reseller account and somehow the usernames for both were the same.

till 18th May 2007 10:24

Is the user account listed correctly in the database table sys_user ? Or is it listed twice? Then change one of the usernames in this table.

smartcall 18th May 2007 10:55

Currently the account username is different, but still, he can't login. It is listed in the database table sys_user. With the same other attributes as this user's other reseller account.

Maybe I could create another reseller, then a user for him and move all websites to the new user?

till 18th May 2007 11:02

Quote:

Originally Posted by smartcall
Maybe I could create another reseller, then a user for him and move all websites to the new user?

This will work of course, but i hope we will find another solution.

Please edit the user entry in the sys_user table and set a new password with e.g. phpmyadmin. The password is md5 encrypted and stored in the "passwort" column.

A SQL statement like this should work:

Code:

update sys_user set passwort = md5('newpassword') WHERE username = 'resellerusername';

smartcall 18th May 2007 11:14

Thanks.

That solved the problem. Strange is why this didn't work from thr frontend?

till 18th May 2007 11:22

Quote:

Originally Posted by smartcall
That solved the problem. Strange is why this didn't work from thr frontend?

It might be that the connection between reseller and cp user is somewhat broken. Please check if the "doc_id" of the user from the table sys_user is correct in the column reseller_userid in the table isp_isp_reseller for this reseller.

DrmCtchr 12th November 2008 04:09

I have the same problem it seems due to the fact that isp_isp_reseller doesn't seem to contain anything. I have noticed that all the historical backups of sysdb all contain this instead of a list of resellers:

Code:

LOCK TABLES `isp_isp_reseller` WRITE;
/*!40000 ALTER TABLE `isp_isp_reseller` DISABLE KEYS */;
/*!40000 ALTER TABLE `isp_isp_reseller` ENABLE KEYS */;
UNLOCK TABLES;

I'm pretty sure there should be at least one insert between the comments, right?

I'm not really sure how to recreate my resellers. If someone can help me script a reseller recovery perl script or at least point me in the right direction of where I can get the reseller data from and a proper way to reinsert it into the database.. It would be most kind.

Thank you all in advance,

David.

DrmCtchr 12th November 2008 05:01

Obviously, I cant get ALL the data from other places in the database. But if I could at least recreate their record in isp_isp_reseller then I could login as the administrator and manually edit the field info in the UI. Luckily for me there wasn't very many resellers.
D

rdtech 26th March 2009 01:03

I'm getting an error with ispconfig. Everything worked fine. I logged in and then while in the systems area, it kicked me off. Now I can't log in at all. I've tried the other account with no luck.

I logged into phpmyadmin and changed the password but it still doest not work. Any idea
Falk?

Till?

http://domain:81/login.php?err=

I've tried restarting the server as well. Theres a problem somewhere but I dont' know where. It doesnt take to me into the back in. If I put in a fake uname and password, then it takes me to an error 101 page

falko 26th March 2009 19:28

Please check if the MySQL details are correct in /home/admispconfig/ispconfig/lib/config.inc.php.


All times are GMT +2. The time now is 18:41.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.