HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   web site install (http://www.howtoforge.com/forums/showthread.php?t=12671)

cruz 13th May 2007 08:06

web site install
 
I created a website in ispconfig. I uploaded the wesite php script to the web folder in the site I created. It will not launch in the browser. I get
HTML Code:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@apostolichearts.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------------

Apache/2.2.3 (CentOS) Server at www.apostolichearts.com Port 80

. I can bring up the web site for the servers domain name.There is a web page telling me that it is a shared ip and to type in the url to the site I want to reach.(the domain I used when I installed the server)I can ping www.mysite.com (the site I am trying to setup in ispconfig)and it comes back ok and with the correct ip address. No packet loss. I created a test php script and put it in the web dir and it will not work. I can put in www.mysite.com:81 and get to the ispconfig sighn up page. Do you know what is wrong here or what I can try to get the script to install or to see if the site is working correct ?

till 13th May 2007 12:27

This is most likely a problem with the ,htaccess file, that you uploaded. Please check the error log of the website for a detailed error message.

cruz 13th May 2007 18:46

error log
 
Is it called (log) in the var/www/web1/www.website.com/log? Are you saying that the file may have changed as it was uploaded or maybe corrupt ?

falko 14th May 2007 16:37

The error log usually is in /var/log/httpd or /var/log/apache2 or similar.

Make sure that the modules mentioned on http://httpd.apache.org/docs/2.2/howto/htaccess.html are enabled in your Apache.

cruz 14th May 2007 23:50

found in logfile
 
I found this in the log file. [HTML][Sat May 12 21:58:47 2007] [error] [client 192.168.1.111] File does not exist: /var/www/sharedip/test.php
[Sat May 12 21:59:29 2007] [error] [client 192.168.1.111] File does not exist: /var/www/sharedip/index.php
[Sat May 12 22:18:17 2007] [error] [client 192.168.1.1] File does not exist: /var/www/sharedip/:80/HTML] Why dose it say sharedip? I was trying to run a simple php script to see if php was working. But I did not use sharedip as the domain. I used the sites domain I set up.

till 15th May 2007 11:40

Please have a look in the error log (error.log) in the directory:

var/www/web1/www.website.com/log/

cruz 15th May 2007 20:01

log file entries
 
HTML Code:

Sun May 13 10:04:24 2007] [alert] [client 192.168.1.111] /var/www/web1/web/.htaccess: Options not allowed here
[Mon May 14 15:19:31 2007] [alert] [client 192.168.1.111] /var/www/web1/web/.htaccess: Options not allowed here
[Mon May 14 15:19:31 2007] [alert] [client 192.168.1.111] /var/www/web1/web/.htaccess: Options not allowed here
[Mon May 14 15:19:39 2007] [alert] [client 192.168.1.111] /var/www/web1/web/.htaccess

I have to change somthing in apache conf file?

edge 15th May 2007 20:48

for your information, I can see your site okay "vDeck Welcome to your future Website
In order to view your website, please remove this file "index.html" and replace it with your own index.html file."

The error you see in your logfile is caused by the .htaccess file.

If you post the .htaccess file here we might see what is wrong with it.

You could also comment out line by line in the .htaccess file (with a # infront of the line), and see what line is causing the problem, and try to find a fix for it.

cruz 16th May 2007 20:23

web site
 
That is the place I got my domain from. I have not redirected it yet. Do I need to have it redirected before I can set up the site on the server ? I am going to take all files out of web folder and try and run a simple index.html page to see if it is working.

cruz 16th May 2007 21:18

found in apache config file
 
I found this in the httpd.conf file. Is this supose to be in there?
HTML Code:

[root@server1 conf]# vi httpd.conf
#    ServerName dummy-host.example.com
#    ErrorLog logs/dummy-host.example.com-error_log
#    CustomLog logs/dummy-host.example.com-access_log common
#</VirtualHost>

<Directory /var/www/sharedip>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

This is were the sharedip is comming from.


All times are GMT +2. The time now is 12:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.