HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   I get no emails - Postfix Problem (http://www.howtoforge.com/forums/showthread.php?t=12625)

Lausch 10th May 2007 20:21

I get no emails - Postfix Problem
 
Hi Guys,

i reinstalled my system now 6 times, i think now its enough i give up.

also google and research in global forums doesn't helped me.

please guys. help me!

The Problem

I cannot get receive any email

my postfix conf:

Quote:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.


myhostname = localhost
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = nfs-rbx.ovh.net, ns30****.ovh.net, localhost.ovh.net, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all


smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names

i tryd many many many and i saw the following maybe helpful things to correct this error.

if i try to call the Maildir Shortcut on my FTP-Root i get an error
if i call the shortcut on ssh it works
maybe this isnt the problem, i just want to say all i now.

---

my domains seems successful routet to my server

mx are mail.domain.tld

i can send emails and DONT get mailer daemon back
if i want to receive emails i dont get any error just no mails
if i disable the DNS on domain setup i cannot send or receive emails
the sender get mailer daemon back
if i enable DNS for the domain i see the entry on the DNS manager

DNS ip = serverip
mx = my DNS server ns30****.ovh.net
i also tryd the domain and the ip for the mx server

i can login but dont get emails. just only can send
Maildir are always empty

Maildir ist activated!

--

Please guys, help me, where can be the problem?

i use etch php5 and apache2 used the perfect installation tutorial from howtoforge

Greets

Lausch

JaJunk 10th May 2007 21:46

might try a 3rd party MX lookup to make sure the mail is going to the correct server. I had same problem and only then did I realize the people I registered the name with had their own server as MX0. I think I found it by googling "MX lookup". Also try local emails (one system user to another) to see if you box works.

Lausch 10th May 2007 23:07

i made a test...
 
hi

i made a mx test:

Quote:

100 ns30****.ovh.net 91.121.***.*** 3600
Quote:

RESULT: ns30****.ovh.net
Banner: localhost ESMTP Postfix (Debian/GNU) [1031 ms]
Connect Time: 0.125 seconds - Good
Transaction Time: 1.75 seconds - Good
Relay Check: OK - This server is not an open relay.
Rev DNS Check: OK - 91.121.***.*** resolves to ns30****.ovh.net
GeoCode Info: Geocoding server is unavailable
Session Transcript:
HELO mxtoolbox.com - DIAGNOSTIC TEST - See http://www.mxtoolbox.com/Policy.aspx
250 localhost [109 ms]
HELO mxtoolbox.com
250 localhost [125 ms]
MAIL FROM: <test@mxtoolbox.com>
250 2.1.0 Ok [125 ms]
RCPT TO: <test@mxtoolbox.com>
554 5.7.1 <test@mxtoolbox.com>: Relay access denied [109 ms]
QUIT
221 2.0.0 Bye [125 ms]
Mail goes to correct server
also i told that i don't get a mail delivery if i send an email to my server

i found something on my pop3 config on courier

maybe this is the reason?

Quote:



RANDFILE = /usr/lib/courier/pop3d.rand

[ req ]
default_bits = 1024
encrypt_key = yes
distinguished_name = req_dn
x509_extensions = cert_type
prompt = no

[ req_dn ]
C=US
ST=NY
L=New York
O=Courier Mail Server
OU=Automatically-generated POP3 SSL key
CN=localhost
emailAddress=postmaster@example.com


[ cert_type ]
nsCertType = server


this isnt my cert

Greets

Lausch

JaJunk 10th May 2007 23:25

I'd start debugging without SSL, just use plain ol' pop.

I see the myhostname=localhost.
I've never seen that before so I don't know if that will cause problems or not. Try
myhostname = hostnamehere.$mydomain
mydomain = domain.here

Lausch 11th May 2007 01:53

no this not work

but i found something now

May 11 01:50:20 ns300299 postfix/smtp[16694]: connect to nfs-rbx.ovh.net[213.251.184.232]: Connection timed out (port 25)


wtf?

is this the damn error?


nfs-rbx.ovh.net isnt my dns

EDIT: after reconfig postfix with dpkg-reconfigure postfix
it works


damn it works!!! hahah!!!

hey JaJunk without you i never had found this damn bug

many thanks man!!!


All times are GMT +2. The time now is 21:30.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.