HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Web-FTP not working (http://www.howtoforge.com/forums/showthread.php?t=12578)

sinjab 8th May 2007 16:50

Web-FTP not working
 
After logging into Web-FTP, it shows empty (both the tree and the list). FileZilla works fine and shows the home directory.

How to fix this problem?

Thanks

till 9th May 2007 10:57

How large is the website and how many files does it contain approx? The WebFTP is not able to load if your website contains several thousand files and directories.

sinjab 9th May 2007 11:20

Web-FTP is not working with all sites. Even with newly created ones which contain a few files and directories created by ISPConfig by default. I think this problem happened after updating to ISPConfig 2.2.12.

Thanks

falko 10th May 2007 18:14

Are there any error messages in the error log in /root/ispconfig/httpd/logs?

sinjab 11th May 2007 13:18

I've just reupdated to ISPConfig 2.2.12 and the problem still there.

The content of error_log is:
Quote:

[Fri May 11 13:11:55 2007] [notice] Apache/1.3.37 (Unix) PHP/5.2.1 mod_ssl/2.8.28 OpenSSL/0.9.8e configured -- resuming normal operations
[Fri May 11 13:11:55 2007] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Fri May 11 13:15:17 2007] [notice] caught SIGTERM, shutting down
[Fri May 11 13:15:24 2007] [notice] Apache/1.3.37 (Unix) PHP/5.2.1 mod_ssl/2.8.28 OpenSSL/0.9.8e configured -- resuming normal operations
[Fri May 11 13:15:24 2007] [notice] Accept mutex: sysvsem (Default: sysvsem)
The content of access_log is:
Quote:

82.137.200.18 - - [11/May/2007:13:16:03 +0300] "GET /login.php HTTP/1.0" 200 2398
82.137.200.18 - - [11/May/2007:13:16:06 +0300] "POST /login/login.php HTTP/1.0" 200 107
82.137.200.18 - - [11/May/2007:13:16:08 +0300] "GET /login/trylogin.php?v= HTTP/1.0" 302 0
82.137.200.18 - - [11/May/2007:13:16:08 +0300] "GET /index.php? HTTP/1.0" 200 1553
82.137.200.18 - - [11/May/2007:13:16:09 +0300] "GET /isp_manager/navigation.php? HTTP/1.0" 200 7936
82.137.200.18 - - [11/May/2007:13:16:10 +0300] "GET /isp_manager/inhalt_tree.php? HTTP/1.0" 200 28992
82.137.200.18 - - [11/May/2007:13:16:10 +0300] "GET /isp_manager/frame_start.php? HTTP/1.0" 302 0
82.137.200.18 - - [11/May/2007:13:16:10 +0300] "GET /isp_manager/legende.php? HTTP/1.0" 200 361
82.137.200.18 - - [11/May/2007:13:16:12 +0300] "GET /multidoc/edit/edit.php?doc_id=3&doctype_id=1021& HTTP/1.0" 200 12358
82.137.200.18 - - [11/May/2007:13:16:13 +0300] "GET /isp_manager/vorladen.php? HTTP/1.0" 200 557
82.137.200.18 - - [11/May/2007:13:16:13 +0300] "GET /isp_manager/placeholder.php? HTTP/1.0" 200 297
82.137.200.18 - - [11/May/2007:13:16:20 +0300] "GET /capp.php?app=isp_file HTTP/1.0" 302 0
82.137.200.18 - - [11/May/2007:13:16:21 +0300] "GET /index.php? HTTP/1.0" 200 1541
82.137.200.18 - - [11/May/2007:13:16:22 +0300] "GET /isp_file/navigation.php? HTTP/1.0" 200 4933
82.137.200.18 - - [11/May/2007:13:16:23 +0300] "GET /isp_file/inhalt_tree.php? HTTP/1.0" 200 18152
82.137.200.18 - - [11/May/2007:13:16:23 +0300] "GET /isp_file/frame_start.php? HTTP/1.0" 200 3399
82.137.200.18 - - [11/May/2007:13:16:23 +0300] "GET /isp_file/legende.php? HTTP/1.0" 200 361
82.137.200.18 - - [11/May/2007:13:16:25 +0300] "GET /isp_file/vorladen.php? HTTP/1.0" 200 1116
82.137.200.18 - - [11/May/2007:13:16:25 +0300] "GET /isp_file/placeholder.php? HTTP/1.0" 200 297
82.137.200.18 - - [11/May/2007:13:16:28 +0300] "POST /isp_file/frame_start.php? HTTP/1.0" 200 3399
82.137.200.18 - - [11/May/2007:13:16:31 +0300] "POST /isp_file/frame_start.php? HTTP/1.0" 302 0
82.137.200.18 - - [11/May/2007:13:16:32 +0300] "GET /index.php? HTTP/1.0" 200 1541
82.137.200.18 - - [11/May/2007:13:16:33 +0300] "GET /index.php? HTTP/1.0" 200 1541
82.137.200.18 - - [11/May/2007:13:16:34 +0300] "GET /isp_file/navigation.php? HTTP/1.0" 200 6632
82.137.200.18 - - [11/May/2007:13:16:35 +0300] "GET /isp_file/inhalt_tree.php? HTTP/1.0" 200 18153
82.137.200.18 - - [11/May/2007:13:16:35 +0300] "GET /isp_file/frame_start.php? HTTP/1.0" 302 0
82.137.200.18 - - [11/May/2007:13:16:35 +0300] "GET /isp_file/legende.php? HTTP/1.0" 200 361
82.137.200.18 - - [11/May/2007:13:16:37 +0300] "GET /isp_file/edit/ordner.php?&ordner=root&web_id=19 HTTP/1.0" 200 3029
82.137.200.18 - - [11/May/2007:13:16:37 +0300] "GET /isp_file/vorladen.php? HTTP/1.0" 200 1116
82.137.200.18 - - [11/May/2007:13:16:37 +0300] "GET /isp_file/placeholder.php? HTTP/1.0" 200 297

However, when doing /etc/init.d/ispconfig_server restart I get:
Quote:

shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Shutting down ISPConfig system...
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
/root/ispconfig/httpd/bin/apachectl stop: httpd stopped
ISPConfig system stopped!
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Starting ISPConfig system...
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
ISPConfig system is now up and running!
Thanks

till 11th May 2007 22:28

There are no errors in the logs. You got the errors on ISPConfig restart because you executed the start / stop script from within a non existant directory.

sinjab 12th May 2007 05:26

Yes, I was trying to execute restart from install_ispconfig after it had been deleted. However, Web-FTP is still showing empty.

Thanks

till 12th May 2007 10:33

Please post the output of:

netstat -tap | grep ftp

gzs 12th May 2007 19:35

Hi,
I have the same problem.
I can access ftp through both FileZilla en the local ftp client (using the domain name and just localhost as the hostname).

My output of: netstat -tap | grep ftp
tcp 0 0 *:ftp *:* LISTEN 4148/proftpd: (acce

I am using ISPConfig Version: 2.2.12 (just a clean install, no upgraded version)

Uploading a file brings me this message: "FTP: Failed to write Array/.htaccess"

LOG Files (and yes, I will see what I can do about that error.ico file message, is this a know issue or am I missing something?):
SERVERNAME:/var/www/web12/user# tail /root/ispconfig/httpd/logs/access_log
xx.xx.xxx.xxx - - [12/May/2007:19:30:56 +0200] "GET /isp_file/frame_start.php? HTTP/1.1" 302 5
xx.xx.xxx.xxx - - [12/May/2007:19:30:56 +0200] "GET /isp_file/legende.php? HTTP/1.1" 200 373
xx.xx.xxx.xxx - - [12/May/2007:19:30:56 +0200] "GET /isp_file/vorladen.php? HTTP/1.1" 200 1128
xx.xx.xxx.xxx - - [12/May/2007:19:30:56 +0200] "GET /isp_file/placeholder.php? HTTP/1.1" 200 309
xx.xx.xxx.xxx - - [12/May/2007:19:30:56 +0200] "GET /isp_file/edit/ordner.php?&ordner=root&web_id=8 HTTP/1.1" 200 8973
xx.xx.xxx.xxx - - [12/May/2007:19:31:00 +0200] "GET /isp_file/edit/ordner_edit.php?web_id=8&ed=new HTTP/1.1" 200 4924
xx.xx.xxx.xxx - - [12/May/2007:19:31:04 +0200] "POST /isp_file/edit/ordner_save.php HTTP/1.1" 302 5
xx.xx.xxx.xxx - - [12/May/2007:19:31:04 +0200] "GET /isp_file/edit/ordner.php?ordner=root:web&web_id=8 HTTP/1.1" 200 3082
xx.xx.xxx.xxx - - [12/May/2007:19:31:05 +0200] "GET /isp_file/edit/file_upload.php?web_id=8 HTTP/1.1" 200 4281
xx.xx.xxx.xxx - - [12/May/2007:19:31:17 +0200] "POST /isp_file/edit/upload_save.php HTTP/1.1" 200 1870

SERVERNAME:/var/www/web12/user# tail /root/ispconfig/httpd/logs/error_log
[Sat May 12 17:56:06 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:56:58 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:57:22 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:57:54 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:58:04 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:58:35 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:59:58 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 18:00:36 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 18:43:35 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 18:44:04 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico

Thanks

falko 13th May 2007 18:51

Quote:

Originally Posted by gzs
Hi,
I have the same problem.
I can access ftp through both FileZilla en the local ftp client (using the domain name and just localhost as the hostname).

My output of: netstat -tap | grep ftp
tcp 0 0 *:ftp *:* LISTEN 4148/proftpd: (acce

I am using ISPConfig Version: 2.2.12 (just a clean install, no upgraded version)

Uploading a file brings me this message: "FTP: Failed to write Array/.htaccess"

LOG Files (and yes, I will see what I can do about that error.ico file message, is this a know issue or am I missing something?):
SERVERNAME:/var/www/web12/user# tail /root/ispconfig/httpd/logs/access_log
xx.xx.xxx.xxx - - [12/May/2007:19:30:56 +0200] "GET /isp_file/frame_start.php? HTTP/1.1" 302 5
xx.xx.xxx.xxx - - [12/May/2007:19:30:56 +0200] "GET /isp_file/legende.php? HTTP/1.1" 200 373
xx.xx.xxx.xxx - - [12/May/2007:19:30:56 +0200] "GET /isp_file/vorladen.php? HTTP/1.1" 200 1128
xx.xx.xxx.xxx - - [12/May/2007:19:30:56 +0200] "GET /isp_file/placeholder.php? HTTP/1.1" 200 309
xx.xx.xxx.xxx - - [12/May/2007:19:30:56 +0200] "GET /isp_file/edit/ordner.php?&ordner=root&web_id=8 HTTP/1.1" 200 8973
xx.xx.xxx.xxx - - [12/May/2007:19:31:00 +0200] "GET /isp_file/edit/ordner_edit.php?web_id=8&ed=new HTTP/1.1" 200 4924
xx.xx.xxx.xxx - - [12/May/2007:19:31:04 +0200] "POST /isp_file/edit/ordner_save.php HTTP/1.1" 302 5
xx.xx.xxx.xxx - - [12/May/2007:19:31:04 +0200] "GET /isp_file/edit/ordner.php?ordner=root:web&web_id=8 HTTP/1.1" 200 3082
xx.xx.xxx.xxx - - [12/May/2007:19:31:05 +0200] "GET /isp_file/edit/file_upload.php?web_id=8 HTTP/1.1" 200 4281
xx.xx.xxx.xxx - - [12/May/2007:19:31:17 +0200] "POST /isp_file/edit/upload_save.php HTTP/1.1" 200 1870

SERVERNAME:/var/www/web12/user# tail /root/ispconfig/httpd/logs/error_log
[Sat May 12 17:56:06 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:56:58 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:57:22 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:57:54 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:58:04 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:58:35 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 17:59:58 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 18:00:36 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 18:43:35 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico
[Sat May 12 18:44:04 2007] [error] [client xx.xx.xxx.xxx] File does not exist: /home/admispconfig/ispconfig/web/themes/original/img/error.ico

Thanks

Please open a new thread for this.


All times are GMT +2. The time now is 10:54.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.