HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   HTTPS site not working. (http://www.howtoforge.com/forums/showthread.php?t=12544)

suidas 7th May 2007 04:20

HTTPS site not working.
 
Hopefully someone in this wonderful forum will be able to help me sort out a problem I've been dealing with for the past two weeks.
I installed ISPConfig and I am able to access the administrator and configure my site. I am running Oscommerce and the way I had it set up on my previous server was that I ran two copies of my site, one I stored in my httpdocs folder and the other in my httpsdocs. SSL connections went to the httpsdocs folder and regular HTTP connections went to my httpdocs folder. I am trying to recreate this setup in my new server with ISPConfig, but I can't get SSL working for my site. I get a page cannot be displayed error when I try to access https://www.mysite.com. When I installed ISPConfig I opted to have the admin work on SSL. I have changed that and now my admin works without SSL. But the admin used to work fine over SSL (the site that I configured has never worked over SSL).
What am I missing? Why can't I get my SSL to work for the site I configured. I enabled it and configured it with the certificate I bought from Verisign and was using in my old server. The old server was also a Linux box. I had CentOS on my old server and I have it on my new one now.
Any help would be greatly, dearly appreciated.
Thanks in advance to all who reply.

till 7th May 2007 08:13

Please enable the SSL checkbox in the site settings, then hit save. Now open the SSL tab that is now visible in the site settings, enter your SSL certificate details and selecet create as action. Then hit save.

suidas 7th May 2007 10:46

I tried that, alas, to no avail. I keep getting the Page cannot be displayed message in IE. I did notice that before I followed the steps you mentioned my Vhosts_ispconfig.conf file did not contain the VirtualHost for the 443 site. Now it does. But I still can't get my page to show up using https://www.mywebsite.com. Do I need to have my domain pointing to my new server's IP address in order to do some testing or can I do my testing through the IP address directly? Should https://myIP work? If not, should I at least get the same message I get when I try to access my server through http://myIP which says that the IP is shared and that I need to access it through a domain name?
Thanks

till 7th May 2007 10:59

Quote:

Do I need to have my domain pointing to my new server's IP address in order to do some testing
Yes, the vhosts are namebased.


All times are GMT +2. The time now is 22:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.