HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Apache Log : Internal Dummy Connection (http://www.howtoforge.com/forums/showthread.php?t=12485)

asyadiqin 3rd May 2007 12:29

Apache Log : Internal Dummy Connection
 
we have had problems on one of our servers recently.
Pages start to load slowly and ultimately the server becomes overwhelmed.

The only suspicious entry in the logs is

Quote:

::1 - - [03/May/2007:11:22:21 +0100] "GET / HTTP/1.0" 403 3931 "-" "Apache/2.2.2 (Fedora) (internal dummy connection)"
This starts off happening every few minutes but then continues to happen with increasing regualrity - ultimately every second.

Thank you.

Hans 3rd May 2007 13:05

Hi,

This warning occurs on Apache 2.2+ systems.
Try to solve that by setting MaxSpareServers to a value, greater than MinSpareServers within your Apache configuration file and restart Apache.

asyadiqin 3rd May 2007 16:52

Quote:

Originally Posted by Hans
Hi,

This warning occurs on Apache 2.2+ systems.
Try to solve that by setting MaxSpareServers to a value, greater than MinSpareServers within your Apache configuration file and restart Apache.

Below is content of my httpd.conf referring to the configuration you specified.

Quote:

<IfModule prefork.c>
StartServers 8
MinSpareServers 5
MaxSpareServers 20
ServerLimit 256
MaxClients 256
MaxRequestsPerChild 500
</IfModule>

<IfModule worker.c>
StartServers 2
MaxClients 150
MinSpareThreads 25
MaxSpareThreads 75
ThreadsPerChild 25
MaxRequestsPerChild 0
</IfModule>
So apparently, that is not the caused. Any other ideas?

bvbmedia 20th June 2013 20:28

FIX: high load caused by Apache Log : Internal Dummy Connection
 
If your default vhost is a heavy dynamic website that is even using mod_rewrite then the fix is easy. :cool:

Create a new vhost, example: default.com.

Add a nice plain index.html file to the /var/www/default.com/web folder so that the vhost is as light as possible.

The trick is to make this vhost the default one.

From SSH type:

mv /etc/httpd/conf/sites-enabled/100-default.com.vhost /etc/httpd/conf/sites-enabled/000-default.com.vhost

Restart Apache:

/etc/init.d/httpd restart

Now the connections to the Apache childrens are being kept alive using the default vhost.


All times are GMT +2. The time now is 11:01.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.