HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ISPConfig Web/FTP Router Access Issues? (http://www.howtoforge.com/forums/showthread.php?t=11991)

nothing111111 10th April 2007 11:21

ISPConfig Web/FTP Router Access Issues?
 
Hi All,

I have recently installed ISPConfig on OpenSuse 10.2 and the basic functionality appears to be working correctly, but I am encountering one particular issue that is really slowing me down. I am unable to access the websites I create within my internal LAN via their names, and as ISPConfig uses virtual hosts I can only access ISPConfig via the IP.

I assume this is due to my router as the sites I create can be accessed correctly externally to my network. So to demonstrate:
If I type in www.mydomain.com from my laptop within my internal network it will automatically take me to my router's admin page as it runs on port 80(I cannot change this or turn it off).
If I type in www.mydomain.com from my computer at work I can access my site (my router is not accessible on port 80 from outside my LAN).

This makes working on my sites and checking them extremely difficult (especially FTP which I am still having problems with). Is there some workaround I can use or do I need to get another router, I assume there are some home users out there who may have run into similar issues?

Cheers,
Nothing111111

P.S Router is a NETGEAR DG834

nothing111111 10th April 2007 11:36

As soon as I posted this question I remembered about hosts files, found a thread and solved. Thanks. :p

Solution On Windows....
search for a file called hosts
add your servers 'IP' [SPACE] 'DOMAIN.COM' to the file. :eek:


All times are GMT +2. The time now is 09:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.