HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   Apache2 don't start /var/www/sharedip don't exist (http://www.howtoforge.com/forums/showthread.php?t=11952)

Dr.Oetker 8th April 2007 11:47

Apache2 don't start /var/www/sharedip don't exist
 
ISPConfig runs with out problems, but today the sites not online.

I try to restart the apache2 server and got this error:

Quote:

Starting web server: Apache2Warning: DocumentRoot [/var/www/sharedip] does not exist
apache2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
(98)Address already in use: make_sock: could not bind to address [::]:443
no listening sockets available, shutting down
Unable to open logs
Whats wrong? Why it works yesterday and now /var/www/sharedip is away?

How can I fix it?

Pleace help me!

Dr.Oetker 8th April 2007 11:55

Okay, i have restart the server and now it works, but the directory /var/www/sharedip does not exist!?

till 8th April 2007 14:16

ISPConfig creates the /var/www/sharedip during setup and does not touch the directory afterwards.

Please create the directory manually. Are there any errrs in the file /home/admispconfig/ispconfig/ispconfig.log?

Dr.Oetker 16th April 2007 15:35

I have created the sharedip directory and checked the ISPConfig Log. There are no errors.

After the Reboot all workes fine, but yesterday, the apache2 goes down and restart dosnt work:

Quote:

apache2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
(98)Address already in use: make_sock: could not bind to address [::]:443
no listening sockets available, shutting down
Unable to open logs
I have rebooted the server, now it works :confused:

Dr.Oetker 22nd April 2007 14:00

Today the apache2 server goes down again.

And it works again after a reboot.
But i wont (and i cant) restart the server every ~ 6 days! What is wrong?

I have looked at the ispconfig. Before the server goes down, there are the following lines:

Quote:

21.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/postfix stop &> /dev/null
21.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 53: cp -f /var/log/mail.log /var/log/mail.log.21-04-07_23-59-01
21.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 55: touch /var/log/mail.log.ispconfigsave
21.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 56: cat /var/log/mail.log >> /var/log/mail.log.ispconfigsave
21.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/proftpd stop &> /dev/null
21.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 58: cp -f /var/log/xferlog /var/log/xferlog.21-04-07_23-59-01
21.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/proftpd start &> /dev/null
21.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.files.myfirstdomain.de
21.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.files.myfirstdomain.de
21.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.images.myfirstdomain.de
21.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.images.myfirstdomain.de
21.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.forum.myfirstdomain.de
21.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.forum.myfirstdomain.de
21.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.eggdrop.myfirstdomain.de
21.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.eggdrop.myfirstdomain.de
21.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.www.myseconddomain.de
21.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/postfix start &> /dev/null
21.04.2007 - 23:59:03 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.www.myseconddomain.de
21.04.2007 - 23:59:03 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.database.myseconddomain.de
21.04.2007 - 23:59:03 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.database.myseconddomain.de
21.04.2007 - 23:59:03 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.galerie.myseconddomain.de
21.04.2007 - 23:59:03 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.galerie.myseconddomain.de
21.04.2007 - 23:59:03 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.gdv.myseconddomain.de
21.04.2007 - 23:59:04 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.gdv.myseconddomain.de
21.04.2007 - 23:59:04 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 124: rm -f /var/log/xferlog.21-04-07_23-59-01
21.04.2007 - 23:59:09 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.files.myfirstdomain.de
21.04.2007 - 23:59:14 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.images.myfirstdomain.de
21.04.2007 - 23:59:20 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 119: rm -f /home/admispconfig/mailstats/web7_forum
21.04.2007 - 23:59:20 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.forum.myfirstdomain.de
21.04.2007 - 23:59:25 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.eggdrop.myfirstdomain.de
21.04.2007 - 23:59:35 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 119: rm -f /home/admispconfig/mailstats/web9_oetker
21.04.2007 - 23:59:35 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 119: rm -f /home/admispconfig/mailstats/web9_acab
21.04.2007 - 23:59:35 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 119: rm -f /home/admispconfig/mailstats/web9_rickwill
21.04.2007 - 23:59:35 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 119: rm -f /home/admispconfig/mailstats/web9_schlumpf
21.04.2007 - 23:59:35 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.www.myseconddomain.de
21.04.2007 - 23:59:41 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.database.myseconddomain.de
21.04.2007 - 23:59:46 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.galerie.myseconddomain.de
21.04.2007 - 23:59:51 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.gdv.myseconddomain.de
21.04.2007 - 23:59:51 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 134: rm -f /var/log/mail.log.21-04-07_23-59-01
The same before the last crash:

Quote:

17.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/postfix stop &> /dev/null
17.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 53: cp -f /var/log/mail.log /var/log/mail.log.17-04-07_23-59-01
17.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 55: touch /var/log/mail.log.ispconfigsave
17.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 56: cat /var/log/mail.log >> /var/log/mail.log.ispconfigsave
17.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/proftpd stop &> /dev/null
17.04.2007 - 23:59:01 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 58: cp -f /var/log/xferlog /var/log/xferlog.17-04-07_23-59-01
17.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/proftpd start &> /dev/null
17.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.files.myfirstdomain.de
17.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.files.myfirstdomain.de
17.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.images.myfirstdomain.de
17.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.images.myfirstdomain.de
17.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.forum.myfirstdomain.de
17.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: /etc/init.d/postfix start &> /dev/null
17.04.2007 - 23:59:02 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.forum.myfirstdomain.de
17.04.2007 - 23:59:03 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.eggdrop.myfirstdomain.de
17.04.2007 - 23:59:03 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.eggdrop.myfirstdomain.de
17.04.2007 - 23:59:03 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 96: cat /dev/null > /var/log/xferlog.www.myseconddomain.de
17.04.2007 - 23:59:03 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 121: rm -f /var/log/xferlog.www.myseconddomain.de
17.04.2007 - 23:59:03 => INFO - /root/ispconfig/scripts/shell/ftp_logs.php, Line 124: rm -f /var/log/xferlog.17-04-07_23-59-01
17.04.2007 - 23:59:07 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.files.myfirstdomain.de
17.04.2007 - 23:59:12 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.images.myfirstdomain.de
17.04.2007 - 23:59:17 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.forum.myfirstdomain.de
17.04.2007 - 23:59:21 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.eggdrop.myfirstdomain.de
17.04.2007 - 23:59:25 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 119: rm -f /home/admispconfig/mailstats/web9_oetker
17.04.2007 - 23:59:25 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 119: rm -f /home/admispconfig/mailstats/web9_acab
17.04.2007 - 23:59:25 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 119: rm -f /home/admispconfig/mailstats/web9_schlumpf
17.04.2007 - 23:59:25 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 132: rm -f /var/log/mail.log.www.myseconddomain.de
17.04.2007 - 23:59:25 => INFO - /root/ispconfig/scripts/shell/mail_logs.php, Line 134: rm -f /var/log/mail.log.17-04-07_23-59-01

But what is the problem? Pleace help me!

(sorry for me bad english, im from germany)

falko 23rd April 2007 18:24

What's in the Apache init script in /etc/init.d? Which distribution do you use?

Dr.Oetker 24th April 2007 14:58

my apache2 init.d file:

Code:

#!/bin/sh -e
#
# apache2              This init.d script is used to start apache2.
#                      It basically just calls apache2ctl.

ENV="env -i LANG=C PATH=/usr/local/bin:/usr/bin:/bin"

#[ `ls -1 /etc/apache2/sites-enabled/ | wc -l | sed -e 's/ *//;'` -eq 0 ] && \
#echo "You haven't enabled any sites yet, so I'm not starting apache2." && \
#echo "To add and enable a host, use addhost and enhost." && exit 0

#edit /etc/default/apache2 to change this.
NO_START=0

set -e
if [ -x /usr/sbin/apache2 ] ; then
        HAVE_APACHE2=1
else
        exit 0
fi

test -f /etc/default/rcS && . /etc/default/rcS
test -f /etc/default/apache2 && . /etc/default/apache2
if [ "$NO_START" != "0" -a "$1" != "stop" ]; then
        [ "$VERBOSE" != no ] && echo "Not starting apache2 - edit /etc/default/apache2 and change NO_START to be 0.";
        exit 0;
fi

APACHE2="$ENV /usr/sbin/apache2"
APACHE2CTL="$ENV /usr/sbin/apache2ctl"

apache_stop() {
        PID=""
        PIDFILE=""
        # let's try to find the pid file
        # apache2 allows more than PidFile entry in the config but only
        # the last found in the config is used
        for PFILE in `grep ^PidFile /etc/apache2/* -r | awk '{print $2}'`; do

                PIDFILE="$PFILE"
                if [ -e "$PIDFILE" ]; then
                        PID=`cat $PIDFILE`
                fi
        done

        if `apache2 -t > /dev/null 2>&1`; then
                # if the config is ok than we just stop normaly

                if [ -e "$PIDFILE" ]
                then
                        PID=`cat $PIDFILE`

                        $APACHE2 -k stop

                        CNT=0
                        while [ 1 ]
                        do
                                CNT=$(expr $CNT + 1)

                                [ ! -d /proc/$PID ] && break

                                if [ $CNT -gt 60 ]
                                then
                                        echo " ... failed!"
                                        echo "Apache2 failed to honor the stop command, please investigate the situation by hand."
                                        exit 1
                                fi

                                sleep 1
                        done
                else
                        echo -n " ... no pidfile found! not running?"
               

fi

        else
                # if we are here something is broken and we need to try
                # to exit as nice and clean as possible

                # if pidof is null for some reasons the script exits automagically
                # classified as good/unknown feature
                PIDS=`pidof apache2` || true

                REALPID=0
                # if there is a pid we need to verify that belongs to apache2
                # for real
                for i in $PIDS; do
                        if [ "$i" = "$PID" ]; then
                                # in this case the pid stored in the
                                # pidfile matches one of the pidof apache
                                # so a simple kill will make it
                                REALPID=1
                        fi
                done

                if [ $REALPID = 1 ]; then
                        # in this case it is everything nice and dandy
                        # and we kill apache2
                        kill $PID
                else
                        # this is the worst situation... just kill all of them
                        #for i in $PIDS; do
                        #      kill $i
                        #done
                        # Except, we can't do that, because it's very, very bad
                        echo " ... failed!"
                        echo "You may still have some apache2 processes running.  There are"
                        echo "processes named 'apache2' which do not match your pid file,"
                        echo "and in the name of safety, we've left them alone.  Please review"
                        echo "the situation by hand."
                fi
        fi
}

# Stupid hack to keep lintian happy. (Warrk! Stupidhack!).
case $1 in
        start)
                [ -f /etc/apache2/httpd.conf ] || touch /etc/apache2/httpd.conf
                #ssl_scache shouldn't be here if we're just starting up.
                [ -f /var/run/apache2/ssl_scache ] && rm -f /var/run/apache2/*ssl_scache*
                echo -n "Starting web server: Apache2"
                $APACHE2CTL startssl
                echo "."
        ;;
        stop)
                echo -n "Stopping web server: Apache2"
                apache_stop
                echo "."
        ;;
        reload)
                echo -n "Reloading web server config..."
                $APACHE2CTL graceful $2
                echo "done."
        ;;
        restart | force-reload)
                echo -n "Forcing reload of web server: Apache2"
                apache_stop
                $APACHE2CTL startssl
                echo "."
        ;;
        *)
                echo "Usage: /etc/init.d/apache2 start|stop|restart|reload|force-reload"
        ;;
esac

My distribution is Debian Sarge 3.1 with ISPConfig 2.2.12

falko 25th April 2007 14:29

Your problem seems to occur at 23:59h, that's the time when ISPConfig stops Apache to process the logs and then starts it again. Maybe the problem is that Apache gets started too soon after it has been stopped. You can try to modify the start section of the init script like this:

Code:

        start)
                [ -f /etc/apache2/httpd.conf ] || touch /etc/apache2/httpd.conf
                #ssl_scache shouldn't be here if we're just starting up.
                [ -f /var/run/apache2/ssl_scache ] && rm -f /var/run/apache2/*ssl_scache*
                echo -n "Starting web server: Apache2"
                sleep 3
                $APACHE2CTL startssl
                echo "."
        ;;


Dr.Oetker 25th April 2007 15:05

I have added "sleep 3", now i hope, the server dont crash any more *g*

(The next time should be the 29th, right?)

thank you!

Dr.Oetker 30th April 2007 11:40

Yesterday it was the Same procedure as every weak.

The Apache goes down and i cant restart him until i reboot the server.


All times are GMT +2. The time now is 08:42.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.