HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Some noob (?) questions... (http://www.howtoforge.com/forums/showthread.php?t=11939)

unreal4u 7th April 2007 14:07

Some noob (?) questions...
 
Hi ;)

Recently installed ISPConfig following the fantastic perfect CentOS Setup.

Everything is working smoothly, but i have some problems:

1.- I can access ftp with my normal users, but NOT with ISPConfig users; AKA the webX_user and his/her password, trough the web interface or ftp clients. (Gives error on both right and left side). FTP access is granted when creating the website.

2.- After i did the entire installation ... i did remember that i made a little mistake: users should have their home in /home/www... and NOT in /var/www/...

Ok, no problem i said; deleted all users from ISPConfig, changed the apache conf, rebooted the machine (just in case), maded a new user in ISPConfig, and surprise: when i go to the website, instead of saying:

"You may now add content to the directory /home/www/html/. Note that until blablabla"

it says: "You may now add content to the directory /var/www/html/. Note that until blablabla"

Is there any way of changing this during post-installation or should i better reinstall ?


My ProFTPD config:

Code:

ServerName                        "ProFTPD server"
ServerIdent                        on "FTP Server ready."
ServerAdmin                        root@localhost
ServerType                        standalone
#ServerType                        inetd
DefaultServer                        on
AccessGrantMsg                        "User %u logged in."
#DisplayConnect                        /etc/ftpissue
#DisplayLogin                        /etc/ftpmotd
#DisplayGoAway                        /etc/ftpgoaway
DeferWelcome                        off

# Use this to excude users from the chroot
DefaultRoot                        ~ !adm

# Use pam to authenticate (default) and be authoritative
AuthPAMConfig                        proftpd
AuthOrder                        mod_auth_pam.c* mod_auth_unix.c

# Do not perform ident nor DNS lookups (hangs when the port is filtered)
IdentLookups                        off
UseReverseDNS                        off

# Port 21 is the standard FTP port.
Port                                21

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask                                022

# Default to show dot files in directory listings
ListOptions                        "-a"

# Allow to resume not only the downloads but the uploads too
AllowRetrieveRestart                on
AllowStoreRestart                on

MaxInstances                        20

# Set the user and group that the server normally runs at.
User                                nobody
Group                                nobody

# Disable sendfile by default since it breaks displaying the download speeds in
# ftptop and ftpwho
UseSendfile                        no

# This is where we want to put the pid file
ScoreboardFile                        /var/run/proftpd.score

# Normally, we want users to do a few things.
<Global>
  AllowOverwrite                yes
  <Limit ALL SITE_CHMOD>
    AllowAll
  </Limit>
</Global>

# Define the log formats
LogFormat                        default        "%h %l %u %t \"%r\" %s %b"
LogFormat                        auth        "%v [%P] %h %t \"%r\" %s"

netstat -tap:
Code:

tcp        0      0 *:imap                      *:*                        LISTEN      2943/dovecot
tcp        0      0 *:http                      *:*                        LISTEN      4678/httpd
tcp        0      0 *:ftp                      *:*                        LISTEN      3015/proftpd: (acce
tcp        0      0 *:ssh                      *:*                        LISTEN      2796/sshd
tcp        0      0 *:https                    *:*                        LISTEN      4678/httpd

Tnx in advance :D

falko 8th April 2007 15:18

Please check that the users created by ISPConfig have the correct homedir in /etc/passwd.
You should also check if all paths are correct in the isp_server table in the ISPConfig database.


All times are GMT +2. The time now is 08:03.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.