HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   SMTP Problem (http://www.howtoforge.com/forums/showthread.php?t=1192)

dorutz 9th November 2005 11:37

SMTP Problem
 
Everything goes smooth when i connect with Outlook to the server, but I can't sent anything. I can receive e-mails from anywhere but I can only send to user@mydomain.

The error:


The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'xxxx@gmail.com'. Subject 'test', Account: 'xxxxxxx.ro', Server: 'xxxxxxx.ro', Protocol: SMTP, Server Response: '554 <xxxx@gmail.com>: Recipient address rejected: Relay access denied', Port: 25, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79

I tryed SMTP without authentification and it does not connect to the server at all. I checked, I have the co-domain created, and in etc/postfix/local-host-names I have too the co-domain.

What can I do?

till 9th November 2005 11:55

In you postfix main.cf, do you have a line like this:

mydestination = /etc/postfix/local-host-names

and also these recipient restrictions (this line may differ a bit, depending on your postfix version):

smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains

dorutz 9th November 2005 13:01

yup
 
yes, i have both. is it good or is it bad? Can't I just accept connections from all for SMTP? How do I do that?

falko 9th November 2005 13:45

Quote:

Originally Posted by dorutz
Can't I just accept connections from all for SMTP?

:eek: No, because then you'd have an open relay which means spammers can use it to send spam from your server!

You have to enable something like "Server requires authentication." in your email client (Outlook). Then you should be able to send emails.

dorutz 9th November 2005 15:40

thanks falko for your answers.
when i enable authentification in outlook, the outlook does not connect at all to the smtp server. i used the same user and pass as in pop but nothing. the smtp keeps asking me for the user and password.
any ideeas?
if i enable smtp for all, i don't think it will be used for spam, cause the server is in an internal network.

falko 9th November 2005 15:47

Do you see anything in the mail log when you try to connect with your email client? Maybe your email client tries to connect to another server because of wrong DNS records...

till 9th November 2005 15:47

Please have a look in your mail log. Did you get any errors?


All times are GMT +2. The time now is 16:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.