HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   The PHP binary coming with ISPConfig does not work properly on your system! (http://www.howtoforge.com/forums/showthread.php?t=11875)

redils 3rd April 2007 23:32

The PHP binary coming with ISPConfig does not work properly on your system!
 
Well I have looked at the other posts related to this error and tried a few things but most people seem to have a different reason for the same error so I figured I would just open a new one with all the information I can give...

Followed the guide for "The Perfect Setup - Ubuntu 6.06 LTS Server (Dapper Drake)"

Quote:

uname -a
Linux kbrosnanul 2.6.15-26-server #1 SMP Thu Aug 3 04:09:15 UTC 2006 i686 GNU/Linux


Below is the output leading up to the error.. If anyone can help I would really appreciate it.

Quote:

Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).

Installing PHP SAPI module: apache
[activating module `php5' in /root/ispconfig/httpd/conf/httpd.conf]
cp libs/libphp5.so /root/ispconfig/httpd/libexec/libphp5.so
chmod 755 /root/ispconfig/httpd/libexec/libphp5.so
cp /root/ispconfig/httpd/conf/httpd.conf /root/ispconfig/httpd/conf/httpd.conf.bak
cp /root/ispconfig/httpd/conf/httpd.conf.new /root/ispconfig/httpd/conf/httpd.conf
rm /root/ispconfig/httpd/conf/httpd.conf.new
Installing PHP CLI binary: /root/ispconfig/php/bin/
Installing PHP CLI man page: /root/ispconfig/php/man/man1/
Installing build environment: /root/ispconfig/php/lib/php/build/
Installing header files: /root/ispconfig/php/include/php/
Installing helper programs: /root/ispconfig/php/bin/
program: phpize
program: php-config
Installing man pages: /root/ispconfig/php/man/man1/
page: phpize.1
page: php-config.1
Installing PDO headers: /root/ispconfig/php/include/php/ext/pdo/
tar: /root/ispconfig/install_ispconfig/compile_aps/../binaries/aps.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
ERROR: Could not create aps.tar.gz
./compile: line 87: cd: /root/ispconfig/install_ispconfig/compile_aps: No such file or directory
./setup2: line 838: cd: /root/ispconfig/install_ispconfig/compile_aps/../..: No such file or directory
cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/aps.tar.gz': No such file or directory
mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
mv: cannot stat `binaries/cronolog': No such file or directory
mv: cannot stat `binaries/cronosplit': No such file or directory
mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
mv: cannot stat `binaries/zip': No such file or directory
mv: cannot stat `binaries/unzip': No such file or directory
tar: spamassassin.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `spamassassin': No such file or directory
tar: uudeview.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `uudeview': No such file or directory
tar: clamav.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `clamav': No such file or directory
tar: aps.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
./setup2: line 860: ispconfig_tmp/php/bin/php: No such file or directory
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!

I'm not sure if it means anything but after this error when I do ls -l in the current directory its all gone.... tar.gz file is gone and the /root/ispconfig folder is gone as well.....

till 4th April 2007 09:38

Quote:

I'm not sure if it means anything but after this error when I do ls -l in the current directory its all gone.... tar.gz file is gone and the /root/ispconfig folder is gone as well.....
Thts is ok, the installer has to remove a failed setup.

Please post the output of:

df -h

Also, did you enter the install_ispconfig directory with the cd command before you execute the setup script? In which directory did you unpack and run the installer? /root/ispconfig will not work, you must unpack and start it from /tmp or another directory that is not /root/ispconfig or /home/admispconfig.

catalyst 4th April 2007 12:16

You may try to install all the openssl* package. (may be missing some packages)
I follow the perfect install of Fedora 6 (32 bit) to my 64-bit CPU by using Fedora 6 (64-bit) which also occurr a smiliar error.
Then I tried to install other openssl* packages (because I don't know which one is actually needed), after that I can install ispconfig successfully.

riVn 4th April 2007 15:03

exactly same problem like redils

redils 4th April 2007 15:23

Quote:

df -h
Filesystem Size Used Avail Use% Mounted on
/dev/hda1 18G 864M 16G 6% /
varrun 506M 88K 506M 1% /var/run
varlock 506M 4.0K 506M 1% /var/lock
udev 506M 88K 506M 1% /dev
devshm 506M 0 506M 0% /dev/shm

This is just a laptop I am using to test out this whole setup before I deploy on my dedicated server.. I will try installing from /tmp and see how it goes. Will keep everyone posted.

riVn 4th April 2007 15:43

i just did it out of /tmp ... same problem

redils 4th April 2007 16:05

Thanks for your help Till. Installing from /tmp worked just fine.

till 5th April 2007 13:14

Quote:

i just did it out of /tmp ... same problem
Please make a new thread. As you see, your problem is not the same, that's why it is always better to make a new thread for a problem instead of posting inside a running thread that is not finished :)

Please post the exact compile error that you got in your installation in the new thread.


All times are GMT +2. The time now is 08:47.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.