HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   The Perfect Setup - Debian Sarge (3.1) Issues (http://www.howtoforge.com/forums/showthread.php?t=1179)

krazy1 8th November 2005 17:17

The Perfect Setup - Debian Sarge (3.1) Issues
 
I have been working my way through the Debian Sarge mail server setup and have run into an issue. When I get to:

Now start saslauthd:

/etc/init.d/saslauthd start

I get the following:

Starting SASL Authentication Deamon: (failed).

I can't figure out why this is failing and I am not sure where to look. I have double checked that I followed the instructions and everything I have matches the instructions. Any help is greatly appreciated.

TIA

falko 8th November 2005 19:07

Do you see anything in the mail log (/var/log/mail.log)?

inversecow 3rd January 2006 16:25

Similar issues with the Ubuntu 5.10 ISP-Server setup
 
Hello,

I have noticed similar issues with the above mentioned How-to. I have verified all of the conf. files mentioned in the How-to itself, and have been left at a loss. The only error is "Starting SASL Authentication Daemon: (failed)." No entry is made to the mail log (/var/log/mail.log).

That being said, I happened to enter the following in the console and SASL started no problem:

sudo /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -a pam

The only thing I can think of is this. Some how during the process of activation, the startup script does not make reference to the "default settings" file (/etc/default/saslauthd), thus it does not pull the needed info to properly execute.

I am happy to get SASL to start, however I am baffled as to why it did not work as expected.

falko 3rd January 2006 17:20

Quote:

Originally Posted by inversecow
Hello,

I have noticed similar issues with the above mentioned How-to. I have verified all of the conf. files mentioned in the How-to itself, and have been left at a loss. The only error is "Starting SASL Authentication Daemon: (failed)." No entry is made to the mail log (/var/log/mail.log).

That being said, I happened to enter the following in the console and SASL started no problem:

sudo /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -a pam

Did you try to start saslauthd as root?
Run
Code:

/etc/init.d/saslauthd start
as root.

inversecow 3rd January 2006 17:26

Thanks for the quick reply. :-)

I tried this as root, and the result was the same(Starting SASL Authentication Daemon: (failed).) Is there a method to produce more verbose error messages within the init.d scripts? Perhaps such would give a direction to move in.

falko 3rd January 2006 17:37

Did you follow the Ubuntu tutorial to the letter? Maybe you made a typo somewhere. Please check your settings again (e.g. configuration files, paths, etc.).

nenad 6th May 2006 15:00

Same problem here.
Starting SASL Authentication Deamon: (failed)

I installed ISPConfig 2.2.2 on two Debian boxes in past 7 days.
First time ther were no errors.
Today there are errors.

Only difference between two installs is MySQL 4.0xx and 4.1

falko 6th May 2006 18:18

Make sure you follow the tutorial to the letter. It is working for me like that, and I've used it so many times now to set up servers and never had any problems.
Maybe you made a typo somewhere.

Norman 9th May 2006 12:16

Edit. I had the same issues when upgrading from mysql-server 4.0 to 4.1.
If you cant stop saslauthd verify that it isn't still running

/etc/init.d/saslauthd stop
If it says "Stopping SASL Authentication Daemon: (not running)."
then run:
ps aux|grep sasl

If you get any lines such as:
root 13413 0.0 0.0 6556 1580 ? Ss 12:20 0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root 13414 0.0 0.0 6556 1580 ? S 12:20 0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root 13415 0.0 0.0 6556 1580 ? S 12:20 0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root 13416 0.0 0.0 6556 1580 ? S 12:20 0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root 13417 0.0 0.0 6556 1580 ? S 12:20 0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam


issue command:
killall -9 saslauthd

and then try to run /etc/init.d/saslauthd start
should return"Starting SASL Authentication Daemon: saslauthd.".

Good luck!

nenad 9th May 2006 12:44

Quote:

Originally Posted by falko
Make sure you follow the tutorial to the letter. It is working for me like that, and I've used it so many times now to set up servers and never had any problems.
Maybe you made a typo somewhere.

Falko, I do not think that anyone is actually typing.
Why should we? You created very good "copy & paste" manual.


All times are GMT +2. The time now is 18:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.