HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Bind Starting Errors (http://www.howtoforge.com/forums/showthread.php?t=11733)

dabro51 28th March 2007 23:09

Bind Starting Errors
 
I have a problem getting Bind to start. I am using FC5-64, followed the perfect install. I have ISPConfig 2-2.6 installed and everything seems fine except getting Bind to run. When installing FC5 after downloading bind and creating the chroot environment it would not start. It kept saying it could not find the named.conf file. I copied named.conf located in /etc/named.conf to /var/named/chroot/etc/named.conf and it started. After installing ISPConfig, bind is running but all the changes made in the control panel are not being written to the named.conf in /var/named/chroot/etc/named.conf, they are being written to in the /etc/named.conf file.

If I delete the /var/named/chroot/etc/named.conf file that I put there Bind gives this error:
"Locating /var/named/chroot//etc/named.conf failed", the two forward strokes should tell me something, that is obviously wrong.

If I copy the /etc/named.conf file to /var/named/chroot/etc/named.conf bind starts working, but changes in the control panel are not being written to in this location.

I've redone the series of chmod commands and links in the named configuration more than once and have not fixed it. Any comments or suggestions would be appreciated. TIA Dave

Hans 28th March 2007 23:34

Try this:

make sure the ROOTDIR-Variable in /etc/sysconfig/named contains
code:
ROOTDIR=/var/named/run-root
Updating via YUM resets it to ROOTDIR=/var/named/chroot

Restart named, i hope it will...

dabro51 28th March 2007 23:46

Did not Seem to Help
 
Thanks Hans for the reply, it just generated:
"/var/named/run-root//etc/named.conf failed error",
I finally just pointed ISPConfig in the "settings" to point to the named.conf file in /var/named/chroot/etc/named.conf, this seems to work now. Thanks, Dave


All times are GMT +2. The time now is 08:13.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.