HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   folder access right problem (http://www.howtoforge.com/forums/showthread.php?t=11698)

catalyst 27th March 2007 17:27

folder access right problem
 
I installed Fedora 6 with ispconfig 2.2.11 and found that my phpscript can't copy or move a file to the created folder (folder was created by php script).
Because the owner of the created folder is "apache" and access right is 644 (default). So that php script can't copy or move files into the new created folder.
Someone say that it can use suphp to solve the access right problem.
But I want to know that are there any solution can change the default access right of the folder to mod 755.
Can I modify some config. file to change the default access right?

till 27th March 2007 21:53

You can change the permissions e.g.in your ftp client or on the shell.

The correct solution for the problem is to use suphp which is supported by ISPConfig.

catalyst 28th March 2007 05:53

Hi Till

It is useless for changing the permissions by ftp or shell. Because the folder is created by php script and the default owner is "apache:apache" with access right 644. So that the php script can't copy or move files in the created folder. Besides, the scripts will created a many sub-folders in the created folder too, it is impossible for me to chmod it to 777 manually.
Can I modify any configuration file and make the default owner to become "web1_user:web1" or change the access right to 777?

I know that suphp can solve this problem. Are there any instructions for setting it up with Fedora 6 (64-bit) & ispconfig?
Thank you!

till 28th March 2007 07:54

Quote:

Can I modify any configuration file and make the default owner to become "web1_user:web1" or change the access right to 777?
My answer is the same then in my 1st post:

The correct solution for the problem is to use suphp which is supported by ISPConfig.

catalyst 28th March 2007 18:18

Quote:

Originally Posted by till
My answer is the same then in my 1st post:

The correct solution for the problem is to use suphp which is supported by ISPConfig.

Hi Till

Could you post a tutorial about how to install suphp for Fedora 6 and ISPConfig?
I only find that I can use "yum install mod_suphp", but don't know how to continue to setup the suphp!
Thanks!

till 29th March 2007 09:38

Quote:

Originally Posted by catalyst
Could you post a tutorial about how to install suphp for Fedora 6 and ISPConfig?

Generally yes, but I'am not able to write this in the next few days.

catalyst 29th March 2007 09:48

Quote:

Originally Posted by till
Generally yes, but I'am not able to write this in the next few days.

Ok! Hope that you will post it earlier.
Hope that you can give a hand on this matter. Many thanks!

I try to use yum install mod_suphp, but there is no document on Fedora 6 with ispconfig, so that I can't setup it successfully.
I have read other post about suphp but can't find out the exact step and procedure to use it. After I used "yum install mod_suphp, the system already load it automatically.

Now I can copy files or create folder occasionally (in fact, seldom) in the php scripts and the created folder will have access right with 755 but sometimes 644.....


All times are GMT +2. The time now is 20:43.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.