HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   systemimage si_getimage error (http://www.howtoforge.com/forums/showthread.php?t=116)

cmpanel 13th July 2005 06:16

systemimage si_getimage error
 
On RH9.0, golden client is running fine as below.

root 11504 0.0 0.1 1708 612 ? S 12:15 0:00 rsync --daemon --config=/tmp/rsyncd.conf.11318

But when I run below getting image I get below error, what am I missing here ? I installed the deps as instructed in the systemimager site.

[root@server tmp]# si_getimage -golden-client xxx.xxx.xxx.83 -image cmpanel
Can't locate XML/Simple.pm in @INC (@INC contains: /usr/lib/systemimager/perl /usr/lib/perl5/5.8.2/i386-linux-thread-multi /usr/lib/perl5/5.8.2 /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl .) at /usr/lib/systemimager/perl/SystemImager/Server.pm line 23.
BEGIN failed--compilation aborted at /usr/lib/systemimager/perl/SystemImager/Server.pm line 23.
Compilation failed in require at /usr/sbin/si_getimage line 45.
BEGIN failed--compilation aborted at /usr/sbin/si_getimage line 45.
[root@server tmp]#

Would appreciate comments/advice

falko 13th July 2005 10:31

You have to install the Perl module XML::Simple.

Open the Perl shell (please go sure to switch off your firewall before!):

Code:

perl -MCPAN -e shell
If you open it for the first time, you have to answer a few questions, but you can mostly accept the default values. Then install the needed module:

Code:

install XML::Simple
To leave the Perl shell, type q.

Code:

q
That's it! :)


All times are GMT +2. The time now is 04:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.