HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   Round Cube webmail with ISPConfig (http://www.howtoforge.com/forums/showthread.php?t=11586)

Hagforce 22nd March 2007 20:15

Round Cube webmail with ISPConfig
 
Hello

I`m running ISPConfig on my server.
Some people have problems logging in to uebimiau at port 81.
So I added webmail.domain.com in ISPConfig an put a Round Cube install there.
I followed the install guide but all I get is a blanck page...

Anyone got experiense in installing Round Cube on a ISPConfig installation?

Hans 22nd March 2007 20:58

Have a look here:
http://www.howtoforge.com/forums/sho...e+blank+screen

Hagforce 22nd March 2007 21:16

Thank you Hans.

But I don`t even get in to the login page.... I get nothing.

The mysql database is working, and the tables is there.

:confused:

Hans 22nd March 2007 21:22

Check if there is still a .htaccess file within your RoundCube's webX/web

It is not visible, so remove it with the command:

rm .htaccess

And try again to login.

If you use the Maildir format, make sure it enabled on your server!

Hagforce 22nd March 2007 21:25

Nope, I deleted that one.

I also tried to delete it all, and did it over again (including the sql db) but just the same.

Hans 22nd March 2007 21:29

Did you enable php Safe mode for that web?
If so, turn it off and try again...

Hagforce 22nd March 2007 21:32

Nope, sorry, php safe mode is off.
Realy strange, I get nothing.

Hans 22nd March 2007 21:38

If you still have a blank page carefully check you have entered the MySql username correctly in db.inc.php.

Hagforce 22nd March 2007 21:46

I got:

Code:

*/

mysql://roundcubeuser:hGhGGFD546311@localhost/roundcube

// PEAR database DSN for read/write operations
// format is db_provider://user:password@host/databse
// currentyl suported db_providers: mysql, sqlite

$rcmail_config['db_dsnw'] = 'mysql://roundcube:pass@localhost/roundcubemail';
// postgres example: 'pgsql://roundcube:pass@localhost/roundcubemail';
// sqlite example: 'sqlite://./sqlite.db?mode=0646';

// PEAR database DSN for read only operations (if empty write database will be used)
// useful for database replication
$rcmail_config['db_dsnr'] = '';

// database backend to use (only db or mdb2 are supported)
$rcmail_config['db_backend'] = 'db';

in my db.inc.php, and the mysql login is correct and tested from command line.

Hans 22nd March 2007 21:59

I still see the default line, which is:

$rcmail_config['db_dsnw'] = 'mysql://roundcube: pass@localhost/roundcubemail';

You should change that into:

$rcmail_config[’db_dsnw’]=’mysql:// web1_u1:mysqlpassword@localhost/web1_db1’;

Explanation:
"web1_u1" is the mysqluser for the website (in this example =web1).
"mysqlpassword" is the password for mysql user web1_u1.
"web1_db1" is the databasename for web1.

All as defined within ISPConfig under the "Options" tab, where you can define the database for your website.


All times are GMT +2. The time now is 02:46.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.