HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   MyDNS with MyDNSConfig Control Panel and DNSMasq on Ubuntu 6.10 (http://www.howtoforge.com/forums/showthread.php?t=11546)

curiogeo 21st March 2007 04:46

MyDNS with MyDNSConfig Control Panel and DNSMasq on Ubuntu 6.10
 
After running through the tutorial I tried to log in to the myconfig interface and I was presented the following error.

Fatal error: Call to undefined function mysql_connect() in /usr/share/mydnsconfig/lib/classes/db_mysql.inc.php on line 75

I have tried to reinstall php5-mysqli using the aptitude method and it is a no go.

Has anyone else seen this error and can you direct me to a solution?

slapper 21st March 2007 12:15

1 Attachment(s)
yep!!!

exactly the same problem here
here is the screen shot

any ideas??

curiogeo 21st March 2007 17:47

Found it
 
It seems the /etc/php5/apache2/php.ini file needs to be updated for this tutorial to work.

Uncomment:
extension=mysql.so

This worked to eliminate the error for me.

Found this in the following post:
http://www.idealog.us/2005/01/howto_fix_fatal.html

Hope this helps you.

Hopefully the tutorial will be updated to mention this potential failure point.

slapper 21st March 2007 18:49

unfortunately the same problem:( :(

i had already uncomment extension=mysql.so
from some previously configurations..

falko 22nd March 2007 18:27

Please install php5_mysql:
Code:

apt-get install php5_mysql
and restart Apache.

slapper 22nd March 2007 18:38

i have already install php5-mysql
but i remove it and install it again the same problem..:rolleyes: :rolleyes:

I will try to follow again the how to..
Is it possible to have problem because of the virtual hosts??
i have a symbolic link in /var/www/mainsite

mydnsconfig -> /usr/share/mydnsconfig/web/
but i don't thing is a problem..

Thanks o lot for the answer!!

falko 22nd March 2007 19:08

Then make sure you have
Code:

extension=mysql.so
in your php.ini. Don't forget to restart Apache.
Create a PHP script like this:
PHP Code:

<?php
phpinfo
();
?>

and call it in your browser. Do you see MySQL support in the output?

slapper 22nd March 2007 19:23

yes mysql support is ok from the output
moreover i already run successful jinzora , gallery2, cmsmadesimple
and postfix with virtual users.

Quote:

MySQL Support enabled
Active Persistent Links 0
Active Links 0
Client API version 5.0.24a
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/run/mysqld/mysqld.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient
i will try to reinstall mydns and i will come back:D :D :D


All times are GMT +2. The time now is 14:38.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.