HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ISPconfig Virtual Hosts + Perfect setup Problem ? (http://www.howtoforge.com/forums/showthread.php?t=11423)

orasis 16th March 2007 01:00

ISPconfig Virtual Hosts + Perfect setup Problem ?
 
I am on a fresh installation of linux suse 10.1 on my laptop based on "The Perfect Setup - SuSE 10.1" step by step. Works fine, I have done this many many times this week trying to install the ISPconfig and understand the installation as much as possible. I had done many mistakes this week but finaly I ended up with a "perfect" installation except this:

near the end of the ISPconfig installation I get this message about the virtual hosts:

Code:

Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system:
1) HTTPS
2) HTTP
Your Choice: 1

Connected successfully to MySQL server
ls: /etc/apache2/vhosts.d/*.conf: No such file or directory
ls: /etc/apache2/vhosts.d/*.conf: No such file or directory
no crontab for root
Restarting some services...
which: no apachectl in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
Shutting down mail service (Postfix)                                  done
Starting mail service (Postfix)                                      done
Shutting down mail service (Postfix)                                  done
Starting mail service (Postfix)                                      done
Shutting down ProFTPD Server:                                        done
Starting ProFTPD Server:                                              done
Shutting down ProFTPD Server:                                        done
Starting ProFTPD Server:                                              done
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
Please direct your browser to

my question is, is that a serious error ? how do I fix this ? I didn't get asked on any installation part about setting up virtual hosts.

I will appreciate your help, and congrats for perfect setup + ISPconfig existance.

till 16th March 2007 09:26

Quote:

my question is, is that a serious error ? how do I fix this ?
Are you able to login to ISPConfig and create websites and email addresses?
Quote:

I didn't get asked on any installation part about setting up virtual hosts.
You must login in the ISPConfig interface to setup virtual hosts.

orasis 16th March 2007 09:33

thanks for the reply, yes i am able to login just fine but when creating sites I always get the ip shared screen :(

I haven't tried emails yet cause I am stuck in how to create sites that work..

I totaly cannot understand the virtual sites. I cannot see the word Virtual anywhere inside ISPconfig

any help ?

orasis 16th March 2007 10:39

so is that normal to see ?

Code:

ls: /etc/apache2/vhosts.d/*.conf: No such file or directory
ls: /etc/apache2/vhosts.d/*.conf: No such file or directory

I have done nothing wrong when installing suse linux following the perfect setup. anything to do with the 64bit suse ?

till 16th March 2007 10:43

Quote:

so is that normal to see ?
Yes, ISPConfig does not use these directories. ISPConfig uses a file named Vhost_ispconfig.conf which is included in your apache configuration file.

orasis 16th March 2007 10:46

oh ok so I truely did a perfect setup.

thank you very much for your help, you are very helpful


All times are GMT +2. The time now is 00:37.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.