HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Support Tickets - Email End User (http://www.howtoforge.com/forums/showthread.php?t=11347)

Xtreem1986 13th March 2007 11:43

Support Tickets - Email End User
 
Hey again guys!

I had a user enter a support request the other day, and was pretty surprised why a week later they hadn't followed my advice. Turns out, they hadn't realised that I'd replied to their support request because although it sent me an email telling me that someone had requested support, they were not emailed when I updated the request. Its one of those funny things I didn't notice for myself because I've never entered a support request! I have since tested and found that no email was sent when i updated my own support tickets.

Have I just missed something in my configuration, or does ISPConfig just not email the user concerned when their support requests are updated? Perhaps the user has to do something to let ISPConfig know their email address? I do always enter one in the email field when i create a new client. I've tried looking through the manual, but have found no info there.

falko 14th March 2007 21:49

I've just had a look at the source code. Mails should be sent when someone writes a reply.

What's in your mail log when you write a reply?

Xtreem1986 25th March 2007 16:09

Oh completely forgot about this.

My customer's email: dan_davies_2k4[at]hotmail.com
My admin email: admin[at]amarus.co.uk

I created a support ticket with my customer, and received an email from dan_davies_2k4[at]hotmail.com to admin[at]amarus.co.uk. I went and made a reply, and dan_davies_2k4[at]hotmail.com never got a reply!

Here is the log of the mail sent when I made the request:

Code:

Mar 25 15:04:33 apollo postfix/pickup[22536]: 8186140102: uid=108 from=<admispconfig>
Mar 25 15:04:33 apollo postfix/cleanup[23926]: 8186140102: message-id=<20070325140433.8186140102@apollo.amarus.co.uk>
Mar 25 15:04:33 apollo postfix/qmgr[10489]: 8186140102: from=<admispconfig@apollo.amarus.co.uk>, size=535, nrcpt=1 (queue ac$
Mar 25 15:04:34 apollo postfix/pickup[22536]: 2AC5C40103: uid=10001 from=<web1_admin>
Mar 25 15:04:34 apollo postfix/cleanup[23926]: 2AC5C40103: message-id=<20070325140434.2AC5C40103@apollo.amarus.co.uk>
Mar 25 15:04:34 apollo postfix/qmgr[10489]: 2AC5C40103: from=<web1_admin@apollo.amarus.co.uk>, size=390, nrcpt=1 (queue acti$
Mar 25 15:04:35 apollo postfix/local[23947]: 2AC5C40103: to=<admispconfig@localhost.localdomain>, relay=local, delay=1, stat$
Mar 25 15:04:35 apollo postfix/qmgr[10489]: 2AC5C40103: removed
Mar 25 15:04:44 apollo postfix/local[23930]: 8186140102: to=<web1_admin@apollo.amarus.co.uk>, orig_to=<admin@amarus.co.uk>, $
Mar 25 15:04:44 apollo postfix/qmgr[10489]: 8186140102: removed

Then I logged in as admin and made a reply!

Code:

Mar 25 15:06:35 apollo postfix/pickup[22536]: CBD7D40102: uid=108 from=<admispconfig>
Mar 25 15:06:35 apollo postfix/cleanup[24062]: CBD7D40102: message-id=<20070325140635.CBD7D40102@apollo.amarus.co.uk>
Mar 25 15:06:35 apollo postfix/cleanup[24062]: CBD7D40102: to=<unknown>, relay=none, delay=0, status=bounced (No recipients $
Mar 25 15:06:36 apollo postfix/cleanup[24067]: 08F3C40103: message-id=<20070325140635.08F3C40103@apollo.amarus.co.uk>
Mar 25 15:06:36 apollo postfix/qmgr[10489]: 08F3C40103: from=<>, size=2137, nrcpt=1 (queue active)
Mar 25 15:06:36 apollo postfix/local[24070]: 08F3C40103: to=<admispconfig@apollo.amarus.co.uk>, relay=local, delay=1, status$
Mar 25 15:06:36 apollo postfix/qmgr[10489]: 08F3C40103: removed

The clue seems to be "CBD7D40102: to=<unknown>". Any help will be very appreciated!

falko 26th March 2007 16:53

Quote:

Originally Posted by Xtreem1986
The clue seems to be "CBD7D40102: to=<unknown>". Any help will be very appreciated!

Is the client's email address displayed correctly in ISPConfig? Is it even saved in ISPConfig?

Xtreem1986 26th March 2007 17:33

Yeah, it's set in ISPConfig (Master Data for the Client). When I (admin) get sent an email telling me there is a new request it appears to be from the user that submitted the request.

falko 27th March 2007 16:25

I've put it in our bugtracker so we will check it.

gavro 16th April 2007 00:43

I am having the same problem here... PLUS: I also have the same problem when a user replies to you reply once again. No email is sent.

When the admin replies to a support ticket, I get the following line in maillog:
Apr 16 00:32:56 production sendmail[22437]: l3FMWuEM022437: from=admispconfig, size=250, class=0, nrcpts=0, msgid=<200704152232.l3FMWuEM022437@production.vhos ts.nl>, relay=admispconfig@localhost

When replying as user the a reply from admin I get the following line in maillog:
Apr 16 00:34:19 production sendmail[22590]: l3FMYJdf022590: from=admispconfig, size=286, class=0, nrcpts=0, msgid=<200704152234.l3FMYJdf022590@production.vhos ts.nl>, relay=admispconfig@localhost
(which is actually the same...)

In other logs nothing in particular is written.

I'm wondering: is this a bug, or a 'feature'?

till 16th April 2007 07:53

Hi,

as falko posted above, he had added the bugreport to the bugtracker. The problem seems to be that there is no from header set in the mail command.

falko 11th May 2007 01:47

I've just fixed it, so it will be available in the next ISPConfig release. :)


All times are GMT +2. The time now is 11:52.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.