HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Question regarding sendmail AUTH / Relaying denied (http://www.howtoforge.com/forums/showthread.php?t=11014)

wonka 1st March 2007 19:01

Question regarding sendmail AUTH / Relaying denied
 
Hi,

Im using ISPConfig 2.2.10 with Centos 4.4 and sendmail 8.13.1. Ive been trying to configure SMTP auth so any user that would like to use the server for sending mails anywhere should authenticate first with its POP3 login.

Ive followed the tutorials, and the suggestions from the forum, but Im stuck where the user can only send mail to local accounts and when trying to send to another domain (i.e. gmail, hotmail) it gets the following error:

reject=550 5.7.1 <user@gmail.com>... Relaying denied, IP name lookup failed [192.168.1.50]

Of course if I add

192.168.1.50 RELAY

to /etc/mail/access, i get no message and then the user can send. But my question is, isn't the SMTP auth option precisely a way to avoid entering each IP address to the /etc/mail/access file so any user can send mails as long as the user authenticates? Or is it that even if I define SMTP auth I should include in /etc/mail/access all the IPs from the users that are going to use the server?

By the way, when I do:

testsaslauthd -u web1_user -p password

I get "OK Success" so it seems the SASL config is working. And also, if I do

telnet localhost 25
EHLO localhost

I can see 250 AUTH LOGIN PLAIN, so it seems the config is also in place.

Thank you and regards,

Edo

edge 1st March 2007 20:16

Did you enable "My outgoing server (SMTP) requites authentication" in your email client?

wonka 1st March 2007 20:53

Yes, I enabled that option at the e-mail client.

falko 2nd March 2007 13:24

Quote:

Originally Posted by wonka
reject=550 5.7.1 <user@gmail.com>... Relaying denied, IP name lookup failed [192.168.1.50]

The problem is that your mail server "sends" his local IP address instead of your router's public IP address.
What's in /etc/postfix/main.cf?

wonka 2nd March 2007 18:04

The mail server is using a public IP address. The IP that the log shows is the address of the PC where the email is sent using the mail server. If I use a public IP address on the PC, I get the same error, but with different IP:

reject=550 5.7.1 <user@gmail.com>... Relaying denied, IP name lookup failed [public_ip_of_PC_that_sends_the_email]

falko 3rd March 2007 15:56

Is your public IP blacklisted? http://www.mxtoolbox.com/blacklists.aspx


All times are GMT +2. The time now is 14:25.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.