HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   SSL not working for individual site. (http://www.howtoforge.com/forums/showthread.php?t=11000)

FeraTechInc 1st March 2007 04:29

SSL not working for individual site.
 
I recently tried to install zencart with SSL support. However, I have been having some problems.

1. I enabled SSL for the site. Installed the cart then when I tried to access the admin section via SSL I got a -12263 error.

So I edited /root/ispconfig/httpd/conf/httpd.conf and changed SSL to 443

The I edited /etc/apache2/ports.conf and commented out port 443

2. Now when I try to get to the admin section I get a page does not exist error. So have I made progress or have I actually gone backwards?

Some detailed help from ANYBODY who has set up an SSL site using ISPConfig would be GREATLY appreciated.

I have set up ISPConfig originally to use SSL to log in, if that has anything to do with my problem.

till 1st March 2007 08:21

Undo what you did in 1). Never edit this configuration file. You mix up the webserver that serves the controlpanel and the webserver that serves your websites.

The error in 2 results in editing the file in 1.

After you have undone everything you described above and are able to login again:

Have you created a SSL certificate by filling out the fields on the SSL tab of the website and then select "Create" as action to create the ssl certificate?

martinfst 1st March 2007 08:29

Do you use a dedicated IP for the site you want SSL on? You can not have multiple sites with SSL on one IP. One SSL cert == one IP

FeraTechInc 1st March 2007 20:23

I did that but nothing appeared in the "SSL Request:" box after I created the SSL certificate...

martinfst 1st March 2007 20:26

What version of ISPConfig do you use?


All times are GMT +2. The time now is 00:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.