HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Kernel Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=6)
-   -   Following "How To Compile A Kernel - The Debian (Sarge) Way" to install 2.6.20.1 (http://www.howtoforge.com/forums/showthread.php?t=10987)

prude 28th February 2007 20:51

Following "How To Compile A Kernel - The Debian (Sarge) Way" to install 2.6.20.1
 
Hello,

I am trying to install a version of 2.6.20.1 carefully following every step of the guide http://www.howtoforge.com/kernel_compilation_debian. Every step runs fine up until the step in part2 of the guide where I execute the command "mkinitrd.yaird -o /boot/initrd.img-2.6.20.1-default1 2.6.20.1-default1".

- currently running a 2.6.7 kernel:
Linux globoid 2.6.7 #4 Sun Feb 18 15:42:41 CET 2007 i686 GNU/Linux

- every step of the guide runs without errors until I execute "mkinitrd.yaird -o /boot/initrd.img-2.6.20.1-default1 2.6.20.1-default1". This command exits with the following error:

globoid:/tmp# mkinitrd.yaird -o /boot/initrd.img-2.6.20.1-default1 2.6.20.1-default1
yaird error: Could not read output for /sbin/modprobe -v -n --show-depends --set-version 2.6.20.1-default1 evdev (fatal)

I am quite a newbie to this, so please be patient with me :) I hope that this guide is also valid for kernel 2.6.20.1
Any idea what I am doing wrong? Any other files or configuration that would be interesting to investigate?

Thanks in advance,
prude

falko 1st March 2007 21:00

What's the output of
Code:

ls -la /boot
?

Ozzymud 19th January 2010 23:32

I know this is an old thread, but i am working on an old machine :P

i got this exact error when compiling 2.6.18 for an old thinkpad 760xl...

it was my bad, in make menuconfig, i was trying to strip the kernel down as far as possible, evdev is the generic input event interface, and apparently required?

CONFIG_INPUT_EVDEV set to m or y (default was m i think)

again, only replying to such an old thread as it was tough finding a solution on google and i hope this helps someone else later... it bites finding LOTS of hits to various forums of solved errors without a solution in the post :P


All times are GMT +2. The time now is 18:22.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.