HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Problems with clamscan after upgrading to ISPConfig-2.2.10 (http://www.howtoforge.com/forums/showthread.php?t=10826)

wheatie 23rd February 2007 00:30

Problems with clamscan after upgrading to ISPConfig-2.2.10
 
Accidently posted this in the wrong form so here I am posting it again :-)


After upgrading I am now getting the following email headers on all inbound
emails. Unable to find anything usefull in server logs...


X-Virus-Status: Failed
X-Virus-Report: /home/admispconfig/ispconfig/tools/clamav/bin/clamscan error 40
X-Virus-Checker-Version: clamassassin 1.2.3 with clamscan / ClamAV 0.90/2631/Thu Feb 22 15:33:11 2007

After googling i've found the following info..

http://www.gossamer-threads.com/list...av/users/29150


I guess my questions is... will following those instructions fix this issue, and is this a common or known problem.

till 23rd February 2007 12:26

Please try the instructions if they fix your problem and report back. I have not heard of the probelm yet.

porjo 23rd February 2007 13:47

I was getting that identical error also.

I followed the instruction in the google link about changing the clamassassin file i.e:

File /home/admispconfig/ispconfig/tools/clamav/bin/clamassassin

CLAMSCANOPT="--no-summary --stdout --mbox"

Change this to:

CLAMSCANOPT="--no-summary --stdout"


That appears to have fixed the issue. My email header now shows:

X-Virus-Status: No
X-Virus-Checker-Version: clamassassin 1.2.3 with clamscan / ClamAV 0.90/2631/Thu Feb 22 16:33:11 2007
Status: O

wheatie 23rd February 2007 16:11

Yes this does appear to fix the issue.

Herbert 24th February 2007 11:09

Here the same problem, i fixed the bug.

till 24th February 2007 11:28

I will make a official patch for this. It looks as the clamassassin devs know the problem, but they havent released a new version yet.

I really dont know why the clamav guys let a operation fail when a commandline option is added that was valid in the prior version of clamav instead of giving a deprecated message :(

Hans 24th February 2007 12:08

Within /home/admispconfig/ispconfig/tools/clamav/bin/clamassassin i changed that line too. After changing, I can confirm that it is working indeed.

Thanks for the info!

falko 24th February 2007 15:35

I've added it to the ISPConfig bugtracker.

Ben 27th February 2007 09:30

Had the sam on my Debian Sarge.
I changed that file. Do i have to restart any service?
Cause changing this line results in error 50 (Database initialization error.).
Which Database and how can I fix this?

till 27th February 2007 09:33

Quote:

Originally Posted by Ben
Had the sam on my Debian Sarge.
I changed that file. Do i have to restart any service?

No. Normally not.

Quote:

Cause changing this line results in error 50 (Database initialization error.). Which Database and how can I fix this?
Please run:

Code:

/home/admispconfig/ispconfig/tools/clamav/bin/freshclam -d -c 10 --datadir=/home/admispconfig/ispconfig/tools/clamav/share/clamav
I guess your cronjobs are not working at all as I posted in your thread with your stats problems which may cause this problem here too.


All times are GMT +2. The time now is 02:09.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.