HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   RoundCube Mail: Can't recieve or send (http://www.howtoforge.com/forums/showthread.php?t=10726)

ai_77 20th February 2007 02:33

RoundCube Mail: Can't recieve or send
 
We recently moved our server to a new location and finally got the website online. Now I am testing the email function and it seems that I can't send or recieve emails but I can log on and use the program fine otherwise. I did not set the system up so I am a bit lost as to what could be the problem. I've checked the main.inc.php and it seems that everything should be fine, but here are a few of the key settings:

$rcmail_config['default_host'] = 'localhost';
$rcmail_config['default_port'] = 143;
$rcmail_config['smtp_server'] = 'localhost';
$rcmail_config['smtp_port'] = 25;
$rcmail_config['smtp_user'] = '';
$rcmail_config['smtp_pass'] = '';
$rcmail_config['smtp_auth_type'] = '';

These are the settings that worked when it was in the previous office. Now when I send it says Sending message was successful but I never recieve the emails. I checked the error log and found these errors:

[19-Feb-2007 15:51:22 -0800] SMTP Error: SMTP error: Connection failed: Failed to connect socket:
in /home/admispconfig/ispconfig/web/roundcubemail/program/steps/mail/sendmail.inc on line 237

If there is any critical info that I forget to post them please ask and I will see what I can find. I would appreciate any help. Thanks.

till 20th February 2007 07:59

Please post the output of:

netstat -tap

ai_77 21st February 2007 01:29

re: netstat
 
Here is the output of netstat -tap

admin@antec:~$ netstat -tap
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN -
tcp 0 0 *:netbios-ssn *:* LISTEN -
tcp 0 0 *:81 *:* LISTEN -
tcp 0 0 localhost.localdo:46513 *:* LISTEN -
tcp 0 0 antec.qes.net:domain *:* LISTEN -
tcp 0 0 localhost.locald:domain *:* LISTEN -
tcp 0 0 *:ftp *:* LISTEN -
tcp 0 0 localhost.localdoma:ipp *:* LISTEN -
tcp 0 0 localhost.localdoma:953 *:* LISTEN -
tcp 0 0 *:smtp *:* LISTEN -
tcp 0 0 localhost.localdo:35388 *:* LISTEN -
tcp 0 0 *:microsoft-ds *:* LISTEN -
tcp 0 0 localhost.localdo:45769 localhost.localdo:46513 ESTABLISHED-

falko 21st February 2007 22:28

What's the output of
Code:

telnet localhost 25
? What's in /etc/hosts? Which distribution do you use? If it's Fedora or CentOS, is SELinux disabled?

ai_77 22nd February 2007 23:50

telnet reply
 
output for telnet localhost 25:

admin@antec:~$ telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 aracarstar.com ESMTP Postfix (Ubuntu)

falko 23rd February 2007 17:00

Looks ok.
What's in /etc/hosts? Which distribution do you use? If it's Fedora or CentOS, is SELinux disabled?

ai_77 23rd February 2007 20:39

Re: distribution
 
For some reason I don't have a /etc/hosts folder (I wasn't in charge of the initial setup). The server is running Ubuntu. I am not sure what SELinux is.

Oh yeah, I also recently got Roundcube to be able to recieve mail but still not send. (I am not sure how, but I fiddled around with making a sub domain site(e.g. mail.domain.net) and when I added email users to this site they are able to recieve messages.)

Also, might it have anything to do with the External/local mailserver option in ispconfig? Will it help if I configure Roundcube to use my dsl smtp service provided by verizon if possible or should I stick to using "localhost" in smtp option? (As you might tell I am somewhat of a newbie regarding this subject).

till 24th February 2007 11:31

/etc/hosts is a file, not a folder.

Please post a excerpt of your mail log after you send a email with roundcube.

ai_77 27th February 2007 02:22

I figured out what the problem was. Looks like my provider is blocking port 25 to minimize spam. Thanks for your help, I was able to learn a few things along the way.


All times are GMT +2. The time now is 20:09.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.