HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   Can't create SSL certificates (http://www.howtoforge.com/forums/showthread.php?t=10659)

cryptic 17th February 2007 03:02

Can't create SSL certificates
 
When doing a "Create Certificate" the SSL Request and SSL Certificate are blank. Even after a wait several minutes, same thing.

The output of "which openssl" in the console is "/usr/bin/openssl".

I ran a tail on the ispconfig.log and noticed these messages when trying to do the "Create Certificate":

16.02.2007 - 15:41:40 => INFO - Signalfile Set: insert
16.02.2007 - 15:41:49 => INFO - make_ssl_cnf /var/www/web6/ssl/openssl.cnf
16.02.2007 - 15:41:50 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1747: WARNING: could not openssl genrsa -des3 -rand /var/www/web6/ssl/random_file -passout pass:b123a9ed8ac93f9 -out /var/www/web6/ssl/www.site.com.key.org 1024 && openssl req -new -passin pass:b123a9ed8ac93f9 -passout pass:b123a9ed8ac93f9 -key /var/www/web6/ssl/www.site.com.key.org -out /var/www/web6/ssl/www.site.com.csr -days 365 -config /var/www/web6/ssl/openssl.cnf && openssl req -x509 -passin pass:b123a9ed8ac93f9 -passout pass:b123a9ed8ac93f9 -key /var/www/web6/ssl/www.site.com.key.org -in /var/www/web6/ssl/www.site.com.csr -out /var/www/web6/ssl/www.site.com.crt -days 365 -config /var/www/web6/ssl/openssl.cnf && openssl rsa -passin pass:b123a9ed8ac93f9 -in /var/www/web6/ssl/www.site.com.key.org -out /var/www/web6/ssl/www.site.com.key
16.02.2007 - 15:41:50 => WARN - WARNING: could not open file /var/www/web6/ssl/www.site.com.csr
16.02.2007 - 15:41:50 => WARN - WARNING: could not open file /var/www/web6/ssl/www.site.com.crt
16.02.2007 - 15:41:50 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 257: setquota -g web6 0 0 0 0 -a &> /dev/null
16.02.2007 - 15:41:50 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 258: setquota -T -g web6 604800 604800 -a &> /dev/null
16.02.2007 - 15:41:50 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 277: Connected successfully
16.02.2007 - 15:41:50 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
16.02.2007 - 15:41:50 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
16.02.2007 - 15:41:50 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: postmap hash:/etc/postfix/virtusertable
16.02.2007 - 15:41:50 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1230: cp -fr /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf~site

till 17th February 2007 19:19

Please have a look here for the fix from martinfst:

http://www.howtoforge.com/forums/sho...4&postcount=33

cryptic 17th February 2007 23:18

Thanks till, that worked!


All times are GMT +2. The time now is 02:02.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.