HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   index.html make eror (http://www.howtoforge.com/forums/showthread.php?t=10503)

planet_fox 10th February 2007 19:05

index.html make eror
 
Hi

I have the problem all site index.html make a error.
Fehler 500 - Interner Server-Fehler! or Fehler 403 - Verboten!

The rights is corect, it makes on any html sites. I have no change make in
apache.conf ot http.conf . I have apache2 . When I create a new sites with ispconfig it is the same problem.

till 10th February 2007 19:42

Are there any additional errors in the error log?

planet_fox 22nd February 2007 09:41

Nothing under /var/log/apache2/error.log

In Apache conf

Code:

DirectoryIndex index.html index.htm index.shtml index.cgi index.php index.php3 index.php4 index.php5  index.pl index.xhtml

martinfst 22nd February 2007 09:47

This is the wrong error log to look at in this case. Please go to the log directory of the website and loog for a file error.log. So something like
Code:

/var/www/web1/log/error.log

planet_fox 22nd February 2007 15:17

oh I have this found

Directory index forbidden by rule:

ok i have the problem is only the index.html gives a error whenn I type

www.test.de and i can see the site when I type www.test.de/index.html

falko 23rd February 2007 15:58

Can you post the vhost configuration of that web site?

planet_fox 23rd February 2007 16:48

Code:

<VirtualHost 38.192.9.20:80>
SuexecUserGroup web19_ftp web19
ServerName www.web.de:80
ServerAdmin webmaster@web.de
DocumentRoot /home/www/web19/web
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias  /cgi-bin/ /home/times/web19/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /home/www/web19/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
suPHP_Engine on
suPHP_UserGroup web19_ftp web19
AddHandler x-httpd-php .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-php
Alias /error/ "/home/www/web19/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /home/www/web19/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /home/www/web19/user/$1/web/$3
RewriteEngine on
</VirtualHost>


heymrdj 23rd February 2007 20:46

I have this same issue. Unless a directory has an index.html to access, the browser give me a FORBIDDEN! message. So to simply make a folder with some files for download, rather than getting an index page jsut showing the files in there, it says FORBIDDEN! So basically I have to build an index.html file with the directories of the files just to access them.

till 23rd February 2007 21:07

Quote:

Originally Posted by heymrdj
I have this same issue. Unless a directory has an index.html to access, the browser give me a FORBIDDEN! message. So to simply make a folder with some files for download, rather than getting an index page jsut showing the files in there, it says FORBIDDEN! So basically I have to build an index.html file with the directories of the files just to access them.

I dont think ist the same problem. planet_fox gets a error when he has a index.html file and not when he dont have this file.

But back to your problem, to get a directory listing, you must set the option "+indexes" for this directory in the apache configuration.

heymrdj 23rd February 2007 21:20

Quote:

Originally Posted by till
I dont think ist the same problem. planet_fox gets a error when he has a index.html file and not when he dont have this file.

But back to your problem, to get a directory listing, you must set the option "+indexes" for this directory in the apache configuration.

Sorry about that. I misread his problem.

But thanks for the fix, it worked perfectly :D.

*gives a till a cookie*


All times are GMT +2. The time now is 21:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.