HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   FTP Problems? (http://www.howtoforge.com/forums/showthread.php?t=10359)

tsj5j 5th February 2007 13:34

FTP Problems?
 
I'm having alot of problems with ProFTPd.

It appears that everything is fine - website, etc.

However, my users are unable to login to ProFTPd.
ProFTPd is rejecting the user/pass for their ISPConfig login.

Code:

##
# /etc/proftpd.conf
##

# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName                        "ProFTPD Default Installation"
ServerType                        standalone
DefaultServer                        on

# Port 21 is the standard FTP port.
Port                                21

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask                                022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances                        30

# Set the user and group under which the server will run.
User                                nobody
Group                                nogroup

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
DefaultRoot ~

# Normally, we want files to be overwriteable.
AllowOverwrite                on

# Bar use of SITE CHMOD by default
#<Limit SITE_CHMOD>
#  DenyAll
#</Limit>

# A basic anonymous configuration, no upload directories.  If you do not
# want anonymous users, simply delete this entire <Anonymous> section.
<Anonymous ~ftp>
  User                                ftp
  Group                                ftp

  # We want clients to be able to login with "anonymous" as well as "ftp"
  UserAlias                        anonymous ftp

  # Limit the maximum number of anonymous logins
  MaxClients                        10

  # We want 'welcome.msg' displayed at login, and '.message' displayed
  # in each newly chdired directory.
  DisplayLogin                        welcome.msg
  DisplayFirstChdir                .message

  # Limit WRITE everywhere in the anonymous chroot
  <Limit WRITE>
    DenyAll
  </Limit>
</Anonymous>

DefaultRoot ~
IdentLookups off
ServerIdent on "FTP Server ready."


Include /etc/proftpd_ispconfig.conf

Code:

##
# /etc/proftpd_ispconfig.conf
##

###################################
#
# ISPConfig proftpd Configuration File
#        Version 1.0
#
###################################
DefaultAddress 127.0.0.1
<VirtualHost 10.8.0.1>
        DefaultRoot            ~
        AllowOverwrite          on
        Umask                  002
</VirtualHost>
<VirtualHost 127.0.0.1>
        DefaultRoot            ~
        AllowOverwrite          on
        Umask                  002
</VirtualHost>
<VirtualHost 66.90.121.169>
        DefaultRoot            ~
        AllowOverwrite          on
        Umask                  002
</VirtualHost>


martinfst 5th February 2007 14:44

Could you please post the exact error message(s) as you find them in your logs?

tsj5j 5th February 2007 14:46

I'm not sure where the error log is.

Anyways, its not an error in those terms, but more of an invalid user/pass.

ProFTPd doesn't seem to be recognising the client logins.

(Eg. I created a account with username tsj5j and password tsj5j5j and couldn't login to FTP with tsj5j and tsj5j5j)

martinfst 5th February 2007 14:56

The ProFTP logfile can be found at
Code:

/var/log/proftpd/proftpd.log
It might show why the log-in fails. It worked/works for me without any problem.

tsj5j 5th February 2007 15:00

No such log exists, nor any file with the same filename on the server.

martinfst 5th February 2007 15:12

There should be a log file somewhere. What distribution are you using? I just tried myself, and got blocked. Also anonymous login was blocked.

I tried my own server, get the same welcome message, but I can login. Have you enabled the ftp tick box in ISPconfig for this user?

falko 6th February 2007 13:54

Quote:

Originally Posted by tsj5j
(Eg. I created a account with username tsj5j and password tsj5j5j and couldn't login to FTP with tsj5j and tsj5j5j)

Did you create this on the User & Email tab of a web site in ISPConfig? Only the users you create on a User & Email tab can log in to FTP and email.
Please make sure you don't mix up ISPConfig users (e.g. resellers and clients) and system users (create on the User & Email tab).

tsj5j 6th February 2007 14:04

Oops!

I think I did mix them up.

I'll try asap.

latcarf 13th February 2007 15:44

Quote:

Originally Posted by martinfst
The ProFTP logfile can be found at
Code:

/var/log/proftpd/proftpd.log
It might show why the log-in fails. It worked/works for me without any problem.

I am scratching my head on this one because while I do have /var/log folder /proftpd is not anywhere in it. Via console I did find / proftpd and got no results, same with find -name proftpd.

I must be using this command incorrectly since I know I have a working FTP under proFTP because I can connect to it and it does indicate that it is proFTP under a Debian system. (Shouldn't we hide that for security reasons?)

I cannot seem to find a "File Find" on the GUI side of Debian (Gnome) either.

jnsc 13th February 2007 15:51

use locate instead

Code:

updatedb
locate -i proftpd



All times are GMT +2. The time now is 07:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.