HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   need to change toggle settings of php.ini file in SSH (http://www.howtoforge.com/forums/showthread.php?t=10261)

bpstyle 31st January 2007 16:36

need to change toggle settings of php.ini file in SSH
 
I desperately need assistance performing some simple tasks with the settings of the PHP.ini file:

I have a virtual/dedicated server with godaddy.com and I need to 'ENABLE' the registar_globals in the php.ini file.

I recently restored a backed up oscommerce shopping cart which uses MySql database. The database and its tables have been restored successfully and the html files are uploaded, but when I access the shopping cart, I get this browser eror:

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

I've tried using the SSH client, putty to go into the /bin directory to access the php.ini file, but after I enter my username successfully, putty prompts me for the password, but I cannot login because the prompt cursor does not move when I type the password....and when I type the password and hit the 'Enter' key, it simply prompts me for the password again and says access denied.

I know for sure that I have the correct password because I am able to log into Plesk 8.0 from my internet browser and I am also able to ftp into the server with WSftp.

I also checked with godaddy and they were able to login, but they will not go any further to asist me.

I know this is a simple task, so it shouldn't take much for a knowledgable person to help me. I need help ASAP.

Can anyone please come to my assistance?

falko 1st February 2007 18:40

Quote:

Originally Posted by bpstyle
because the prompt cursor does not move when I type the password

That's the normal behaviour.

Are you absolutely sure the password is correct, and that you have shell access (having FTP access doesn't mean you have shell access as well).

If you cannot log in to your shell, you could use an .htaccess file to enable register_globals: http://www.howtoforge.com/forums/sho...bals+.htaccess

Zerko 9th February 2007 22:38

There is a patch so that register globals can be left off.
A bit of code modifying, but step-by-step instructions so you can't go wrong.

http://www.oscommerce.com/community/contributions,2097

http://www.oscommerce.com/community/contributions,2957

bpstyle 13th February 2007 09:04

ssh login finally good-how to toggle registar_globals
 
Thanks for the replies.

I finally got the correct password and logged in successfully.

can you help me with the code to modify that php.ini file?:)

sjau 13th February 2007 11:33

well, it is not recommended turning it off globally... first try to create a .htaccess file in your webroot for that site and add this:

Code:

php_admin_value register_globals Off


All times are GMT +2. The time now is 04:10.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.