HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Can't access control panel through Firefox (http://www.howtoforge.com/forums/showthread.php?t=1024)

benbalbo 28th October 2005 03:28

Can't access control panel through Firefox
 
When I log in to the control panel in Firefox, it hangs shortly after logging in. Sometime as soon as I log in, sometimes I can get as far as adding a new client, and then it hangs, to the extent that I have to force quit the application.

I reinstalled ISPConfig to see if that helped, to no avail.

I then tried accessing it through IE (running Crossover Office) and it works fine. Anyone else have this problem?

There are no entries added to /home/admispconfig/ispconfig/ispconfig.log when up to the point Firefox hangs.

I also don't have the startup script /etc/init.d/ispconfig_server - I'm guessing ISPConfig should have created this.

Running Ubuntu 5.1, Apache 2, PHP 5.1 (from people.debian.org/~dexter), MySQL4.1 - all other apps are as per the perfect install guide for Ubuntu 5.04.

Thanks in advance,
Ben

benbalbo 28th October 2005 05:23

I just tried using Mozilla 1.7.12, and it seems to work fine in this browser.

If it helps, here are the full browser user_agent values:

Mozilla 1.7.12: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051013 Debian/1.7.12-1ubuntu1

Firefox 1.0.7: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)

Internet Explorer 6.0.2800.1106: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

falko 28th October 2005 09:48

Did you follow the Ubuntu tutorial? http://www.howtoforge.com/perfect_setup_ubuntu_5.10

benbalbo 1st November 2005 23:58

To the letter :-)

As I say - the system works in Mozilla and IE, just not in Firefox. Tis very strange.

benbalbo 2nd November 2005 00:06

Oops - just noticed you had 5.10 in the URL - that one wasn't there (or linked to from the ISPConfig docs page at least) when I looked.

I'll take a look and see what the differences are.

Thanks

benbalbo 2nd November 2005 08:54

Well I looked at the differences (very few) and reinstalled - still no Firefox support. There are still no errors in the log files. I'm guessing this is a firefox bug, although how that could be, I don't know...

Thanks for the help though

benbalbo 2nd November 2005 10:17

Here's an interesting developement. My previous posts are for a ubuntu5.1 install. I've now also installed ISPConfig on a VPS running Debian testing, and firefox works fine with that. I'll double check when I get to work tomorrow to see if it's just firefox on my work machine that has a problem.

till 2nd November 2005 11:17

I'am doing all my development on the ISPConfig interface with firefox and never had any problems.

timehost 13th January 2006 02:42

Browser incompatibility
 
Yes we are having the same problem. On Internet explorer 6 ISPCOnfig works fine. On my Linux workstation with Mozilla 1.7.12, I have to refresh manually very often (while changing from ISP Management to DNS Management for example) and hav to logout and login if I add a new site or new user to be able to see it on the tree menu.

till 13th January 2006 11:20

Please check your security settings in Firefox. Javascript and all kinds of header and http redirects must be enabled for ISPConfig.


All times are GMT +2. The time now is 09:53.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.