HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   "Shared IP" page again - why? (http://www.howtoforge.com/forums/showthread.php?t=10235)

bmwpingvinen 30th January 2007 23:12

"Shared IP" page again - why?
 
1 Attachment(s)
Can someone tell me why I get this page even if I access my domains by their names?
I attach my Vhosts_ispconfig.conf file and hope for some clarifcation :)


-s

Craig 31st January 2007 02:45

It could be something as simple as there being the default "index.html" file in the root directories for each web site.

bmwpingvinen 31st January 2007 06:54

Thanks, but no, it isn't that..
the index.html in the /var/www/web../web directories are the "Welcome" ones. Except for the site where I have installed Squirrelmail, where the index.html is removed.

till 31st January 2007 10:19

You get the shared IP page because the domain name points in DNS to another IP address then the IP you selected for this website in ISPConfig.

bmwpingvinen 31st January 2007 14:07

I don't understand how:

]$ dig @localhost www.garnes.no

; <<>> DiG 9.3.3rc3 <<>> @localhost www.garnes.no
; (2 servers found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53037
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;www.garnes.no. IN A

;; ANSWER SECTION:
www.garnes.no. 86400 IN A 85.196.76.14

;; AUTHORITY SECTION:
.
.

------------

<VirtualHost 85.196.76.14:80>
ServerName www.garnes.no:80
ServerAdmin webmaster@garnes.no
DocumentRoot /var/www/web1/web
ServerAlias garnes.no
.
.

Isn't this right?

-s

till 31st January 2007 14:16

Quote:

Isn't this right?
This depends on your setup. If your server is behind a router in a NAT enviroment, you must select your internal IP for the website.

bmwpingvinen 31st January 2007 14:35

Thanks, now I got it right and it works!
I am a little confused after having changed ting som many times back and forth..

Thanks Till!

-s


All times are GMT +2. The time now is 15:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.