HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Default ISPconfig Page (http://www.howtoforge.com/forums/showthread.php?t=1005)

AngelDrago 26th October 2005 05:52

Default ISPconfig Page
 
Hi everyone i followed the http://www.howtoforge.com/perfect_setup_debian_sarge by the letter and i still have problems with the default webpages to show up it tells me
Object not found
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.
Error 404

here is my httpd -V output

Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_SYSVSEM_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT=""
-D SUEXEC_BIN="/usr/lib/apache2/suexec2"
-D DEFAULT_PIDLOG="/var/run/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="/var/run/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="/etc/apache2/mime.types"
-D SERVER_CONFIG_FILE="/etc/apache2/apache2.conf"

is there anything i'm maybe missing :confused: any help is more than welcome as always...

Thnak you,
Angel :eek:

till 26th October 2005 08:15

Please check the ISPConfig log for errors.

/home/admispconfig/ispconfig/ispconfig.log

Espescially for errors where the httpd -t test failed.

AngelDrago 26th October 2005 16:27

1 Attachment(s)
Hi till here it is
ur:~# httpd -t
Syntax OK
i also included the an attachment for your review... maybe we could share some light on this...

Thank you again for the help...
AngelDrago

falko 26th October 2005 17:55

Quote:

Originally Posted by AngelDrago
Hi till here it is
ur:~# httpd -t
Syntax OK
i also included the an attachment for your review... maybe we could share some light on this...

Thank you again for the help...
AngelDrago

The ISPConfig log is ok, no errors/warnings in there.
Can you check if your web sites are in /etc/apache2/vhosts/Vhosts_ispconfig? Can you also check if /etc/apache2/vhosts/Vhosts_ispconfig is included in /etc/apache2/apache2.conf?

AngelDrago 26th October 2005 19:30

1 Attachment(s)
checked it and i see my site in there i included both in a zip for your review and again thank you..

falko 26th October 2005 22:17

Looks ok. Does www.mydomain.com resolve to your server? Is its IP address really 10.10.3.5?

Please post the output of
Code:

ifconfig
here.

AngelDrago 26th October 2005 23:21

here it is...

ur:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:E0:81:22:57:97
inet addr:10.10.3.4 Bcast:10.10.3.255 Mask:255.255.0.0
inet6 addr: fe80::2e0:81ff:fe22:5797/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:74 errors:0 dropped:0 overruns:0 frame:0
TX packets:77 errors:0 dropped:0 overruns:0 carrier:0
collisions:1 txqueuelen:1000
RX bytes:11486 (11.2 KiB) TX bytes:30815 (30.0 KiB)

eth0:0 Link encap:Ethernet HWaddr 00:E0:81:22:57:97
inet addr:10.10.3.5 Bcast:10.10.3.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

eth0:1 Link encap:Ethernet HWaddr 00:E0:81:22:57:97
inet addr:10.10.3.6 Bcast:10.10.3.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

eth0:2 Link encap:Ethernet HWaddr 00:E0:81:22:57:97
inet addr:10.10.3.7 Bcast:10.10.3.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

eth0:3 Link encap:Ethernet HWaddr 00:E0:81:22:57:97
inet addr:10.10.3.8 Bcast:10.10.3.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

eth0:4 Link encap:Ethernet HWaddr 00:E0:81:22:57:97
inet addr:10.10.3.9 Bcast:10.10.3.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

eth0:5 Link encap:Ethernet HWaddr 00:E0:81:22:57:97
inet addr:10.10.3.10 Bcast:10.10.3.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1316 (1.2 KiB) TX bytes:1316 (1.2 KiB)

ur:~#
Thank you,
AngelDrago

falko 26th October 2005 23:30

What's in /etc/apache2/ports.conf?

AngelDrago 27th October 2005 16:40

sorry for the delay...

In the /etc/apache2/ports.conf i only see ...

Listen 80
Listen 443

Thank you
AngelDrago:confused:

falko 27th October 2005 16:58

Please post the output of
Code:

netstat -tap


All times are GMT +2. The time now is 20:09.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.