HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Debian Question II (http://www.howtoforge.com/forums/showthread.php?t=1004)

AngelDrago 26th October 2005 00:17

Debian Question II
 
hi everyone i followed this http://www.howtoforge.com/forums/sho...pache2-default

and my phpinfo page workes only if i go down like http://www.mydomain.com/web1/web/ but not to http://www.mydomain.com/phpinfo.php what steps do i need to do to fix that and again thank you for the kind help...

AngelDrago :eek:

falko 26th October 2005 01:21

If you don't need the default Apache web site in Debian then you can simply run
Code:

rm -f /etc/apache2/sites-enabled/000-default
/etc/init.d/apache2 restart


AngelDrago 26th October 2005 02:36

Danke falko.. did the above as you suggested but sti no go with webpages here is a output of my httpd -V
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_SYSVSEM_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT=""
-D SUEXEC_BIN="/usr/lib/apache2/suexec2"
-D DEFAULT_PIDLOG="/var/run/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="/var/run/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="/etc/apache2/mime.types"
-D SERVER_CONFIG_FILE="/etc/apache2/apache2.conf"
and a directory listing of my path...
ur:/# cd var
ur:/var# dir
backups cache lib local lock log mail opt run spool tmp www
ur:/var# cd www
ur:/var/www# dir
apache2-default web1 webalizer www.mydomain.com
ur:/var/www# cd web1
ur:/var/www/web1# dir
cgi-bin log Maildir phptmp ssl user web
ur:/var/www/web1# cd web
ur:/var/www/web1/web# dir
error index.html info.php
ur:/var/www/web1/web# httpd -V

all seems to be looking good but i do not see my pages to be dispalyed at all...
any ideas on what i can do from here on??

Thank you again for the help..
AngelDrago

till 26th October 2005 08:14

Please check the ISPConfig log for errors.

/home/admispconfig/ispconfig/ispconfig.log

Especially for errors where the httpd -t test failed.

falko 26th October 2005 09:11

Please post the output of
Code:

ls -l /etc/apache2/sites-enabled/

AngelDrago 26th October 2005 16:34

here is the output...

ur:~# ls -l /etc/apache2/sites-enabled/
total 0
ur:~#
hmmm i realy do not know what i'm looking for here... but if i understanded it right i have no sites on my server...

Thank you,
AngelDrago

falko 26th October 2005 17:44

Quote:

Originally Posted by AngelDrago
here is the output...

ur:~# ls -l /etc/apache2/sites-enabled/
total 0
ur:~#
hmmm i realy do not know what i'm looking for here... but if i understanded it right i have no sites on my server...

Thank you,
AngelDrago

No, that means that the default Apache web site isn't available any longer, you know, that placeholder page you see when you access Apache the first time after installation. It's configuration is located in /etc/apache2/sites-enabled/, and it is served from /var/www.
To me it looked like this placeholder page was interfering with the ISPConfig web sites because you had to type http://www.mydomain.com/web1/web/ to access web1.
Your ISPConfig web sites configuration should be in /etc/apache2/vhosts/Vhosts_ispconfig.conf.


All times are GMT +2. The time now is 21:24.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.