PDA

View Full Version : Mail Problem


BlueStream
13th December 2006, 14:39
When using the Uebimail via Tools to send an email, I get this error
SMTP Error: Recipient not accepted. Verify your relay rules

I believe it has not been set up properly. I did however follow the Perfect Setup for Fedora Core 5 to the tee.

I'm on dyndns but I do have a FQDN and I have no idea how to configure my mx.domain.tld.

In the case that you would say dynamic IPs are not allowed in this case, please assume that I have a static IP because that option is also open to me.

Cheers,
Shawn.

planet_fox
13th December 2006, 17:55
Wich mailserver you use ? and pop3server

BlueStream
13th December 2006, 18:00
I followed the Perfect Setup for Fedora Core 5.

I believe it's dovecot. Not too sure about which is which.

planet_fox
13th December 2006, 18:08
dovecot is only imap and pop3 server, have you install postfix and it run ? Postfix is your mailserver . When you have postfix post your main.cf please

BlueStream
13th December 2006, 18:15
postfix has already been installed. (Perfect Setup Fedora Core 5)

planet_fox
13th December 2006, 23:44
your main.conf is not complete configure see in manual on page 4

After these configuration steps you should now have a /etc/postfix/main.cf that looks like this

BlueStream
14th December 2006, 05:54
your main.conf is not complete configure see in manual on page 4

It's page 5 and I ran those commands and the results are at the bottom of main.cf.

Is it one particular part that has been wrongly configured?

falko
14th December 2006, 21:15
Can you post your main.cf here directly (please strip out the comments)?

BlueStream
15th December 2006, 04:36
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
inet_interfaces = all
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.2.8/samples
readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

falko
15th December 2006, 14:03
Please run
postconf -e 'mynetworks = 127.0.0.0/8'
/etc/init.d/postfix restart

BlueStream
16th December 2006, 07:05
Ran that.

Still got the same error.

falko
16th December 2006, 12:10
Can you post an excerpt of your mail log where that error occurs?

BlueStream
16th December 2006, 12:26
Dec 16 18:04:15 s6 postfix/smtp[3074]: connect to parkwebwin-v02.prod.mesa1.secureserver.net[68.178.232.99]: read timeout (port 25)
Dec 16 18:04:15 s6 postfix/smtp[3074]: 708F5A8D2E: to=<username@parkwebwin-v02.prod.mesa1.secureserver.net>, orig_to=<username@subdomain.dyndns.org>, relay=none, delay=253593, status=deferred (connect to parkwebwin-v02.prod.mesa1.secureserver.net[68.178.232.99]: read timeout)

till
16th December 2006, 15:22
Is this the IP of your local server: 68.178.232.99 ?

BlueStream
16th December 2006, 22:29
Is this the IP of your local server: 68.178.232.99 ?

No. As mentioned in first post, I'm on dyndns. But how I set up the server was to use the FQDN as the domain needed for setup.

I'm guessing I may have to edit the data in godaddy? What do I edit?

till
17th December 2006, 13:26
Can you connect to your dyndns subdomain with this command:

telnet subdomain.dyndns.org 25

if you get a response from the mailserver, type:

ehlo localhost

To quit the connection, type:

quit

If this wont work, please double check that:

a) Your provider does not block port 25
b) You forwarded port 25 on your router to the correct internal server IP.
c) That postfix is running on your server and accepting connections.

BlueStream
17th December 2006, 16:18
250-SpeedTouch.lan
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME

falko
17th December 2006, 20:10
Looks ok.

Dec 16 18:04:15 s6 postfix/smtp[3074]: 708F5A8D2E: to=<username@parkwebwin-v02.prod.mesa1.secureserver.net>, orig_to=<username@subdomain.dyndns.org>, relay=none, delay=253593, status=deferred (connect to parkwebwin-v02.prod.mesa1.secureserver.net[68.178.232.99]: read timeout)For some reason mails to subdomain.dyndns.org get redirected to parkwebwin-v02.prod.mesa1.secureserver.net.

Can you post the real name of your dyndns.org domain?

BlueStream
17th December 2006, 20:16
fusionstream.dyndns.org

however when setting the hostname and etc for the server, I used fusionstream.org

I have since acquired a nameserver for fusionstream.org that allows me to update the data dynamically.

BlueStream
18th December 2006, 09:57
OK... I'm have a proper name server...

I can't send from webmail and i don't receive anything...

till
18th December 2006, 13:40
Which messages do you get in the mail log now when you send and receive email.

BlueStream
18th December 2006, 13:56
Dec 18 19:54:11 s6 postfix/smtpd[31512]: connect from localhost.localdomain[127.0.0.1]
Dec 18 19:54:11 s6 postfix/smtpd[31512]: warning: Illegal address syntax from localhost.localdomain[127.0.0.1] in MAIL c$
Dec 18 19:54:11 s6 postfix/smtpd[31512]: lost connection after RCPT from localhost.localdomain[127.0.0.1]
Dec 18 19:54:11 s6 postfix/smtpd[31512]: disconnect from localhost.localdomain[127.0.0.1]


I may see the problem.. lol.. How do I change it eh?

till
18th December 2006, 14:05
I may see the problem.. lol.. How do I change it eh?

Yes, please change the hostname to a valid unique hostname that exists in dns.

1) Change it in /etc/mailname, if this file exists on your server.
2) Change it in /etc/postfix/main.cf, if you find it there.
3) Change it in /etc/hostname and run the command:

hostname -F /etc/hostname

4) Restartart postfix.

BlueStream
18th December 2006, 14:22
Yes, please change the hostname to a valid unique hostname that exists in dns.

1) Change it in /etc/mailname, if this file exists on your server.
2) Change it in /etc/postfix/main.cf, if you find it there.
3) Change it in /etc/hostname and run the command:

hostname -F /etc/hostname

4) Restartart postfix.

1) No file
2) I'm not too sure so I change myhostname. Should I also change mydomain?
3) I change /etc/hosts to 127.0.0.1 fusionstream.org localhost.
Previously hostname was s6.fusionstream.org

How? Getting more and more complicated..

BlueStream
22nd December 2006, 05:48
While trying to send a message to myself:
Dec 22 11:40:05 s6 postfix/smtpd[10668]: warning: Illegal address syntax from fusionstream.org[127.0.0.1] in MAIL command: fusionstream@

Dec 22 11:40:05 s6 postfix/smtpd[10668]: lost connection after RCPT from fusionstream.org[127.0.0.1]

Any ideas?

Turns out I can receive mail... I added fusionstream.org to mydomain yesterday and i received some mail. But it took about ten minutes to be received.

Is it really a good idea to add my domain to mydomain? what about those other FQDNs that I host?

BlueStream
22nd December 2006, 06:14
squirellmail displays no errors but when sending to gmail it does not appear in my gmail inbox..


however, when sending to myself(this mail server's email), it appears in my inbox immediately and it say from FUSIONSTREAM@EXAMPLE.COM

what is up with that?

till
22nd December 2006, 13:21
Please post your main.cf file, comments stripped.

BlueStream
22nd December 2006, 13:37
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
myhostname = fusionstream.org
mydomain = fusionstream.org
inet_interfaces = all
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.2.8/samples
readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names
mynetworks = 127.0.0.0/8

falko
23rd December 2006, 16:48
however, when sending to myself(this mail server's email), it appears in my inbox immediately and it say from FUSIONSTREAM@EXAMPLE.COM

what is up with that?
You must set the correct sender address in your email client (e.g. Thunderbird, Outlook, webmail, etc.).

BlueStream
23rd December 2006, 21:59
You must set the correct sender address in your email client (e.g. Thunderbird, Outlook, webmail, etc.).

squirrelmail does not have this option... The mentioned occurences, I believe, are not the cause but are the symptoms.

till
24th December 2006, 12:32
Squirrelmail has this option for every account, please check under settings.

You can try to set:

myorigin = fusionstream.org

BlueStream
24th December 2006, 12:59
There is no such option via squirrelmail's webpage.

I tried editing via the main.cf and it still does not work..

till
24th December 2006, 13:03
My squirrelmail has this setting. Its under options -> personal settings. (I run squirrelmail in german translation, so the name of the menus may differ a bit).

BlueStream
24th December 2006, 13:36
Ok. It works now in the sense that I can now send messages to myself. or rather, to emails within my domain.

I get no errors when sending elsewhere but the mail never arrives.

Is there any fix to the "FROM" issue with squirrelmail? Because it looks like I have to manually edit this item for each email account I create.

falko
24th December 2006, 15:21
I get no errors when sending elsewhere but the mail never arrives.

What's in your mail log when this happens?
Are the domains you try to send to listed in /etc/postfix/local-host-names?

BlueStream
24th December 2006, 22:37
What's in your mail log when this happens?
Are the domains you try to send to listed in /etc/postfix/local-host-names?

It is not in the said file. It is an "external domain".. i.e. yahoo mail, etc..

Dec 25 04:34:34 s6 postfix/smtpd[3361]: connect from fusionstream.org[127.0.0.1]
Dec 25 04:34:34 s6 postfix/smtpd[3361]: 53884A8DCD: client=fusionstream.org[127.0.0.1]
Dec 25 04:34:34 s6 postfix/cleanup[3362]: 53884A8DCD: message-id=<__SOMENUMBERS__.squirrel@www.fusionstream$
Dec 25 04:34:34 s6 postfix/qmgr[29813]: 53884A8DCD: from=<admin@fusionstream.org>, size=711, nrcpt=1 (queue active)
Dec 25 04:34:34 s6 postfix/smtpd[3361]: disconnect from fusionstream.org[127.0.0.1]
Dec 25 04:34:34 s6 dovecot: imap-login: Login: user=<fusionstream>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.$
Dec 25 04:34:34 s6 dovecot: IMAP(fusionstream): Disconnected: Logged out
Dec 25 04:34:34 s6 dovecot: imap-login: Login: user=<fusionstream>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.$
Dec 25 04:34:35 s6 dovecot: IMAP(fusionstream): Disconnected: Logged out


No mention of my external mail server here. There seems to be some usage of the user name though..

falko
25th December 2006, 14:22
It is not in the said file. It is an "external domain".. i.e. yahoo mail, etc..

Please check the spam folder in your Yahoo account. If you send from a dynamic IP address or are blacklisted, Yahoo will tag your emails as spam.

BlueStream
25th December 2006, 16:03
Please check the spam folder in your Yahoo account. If you send from a dynamic IP address or are blacklisted, Yahoo will tag your emails as spam.

i have already checked at the start.. emails are totally not received..

till
25th December 2006, 22:09
Please check with:

postqueue -p

If the message is still in your local mailqueue.

BlueStream
26th December 2006, 05:05
Please check with:

postqueue -p

If the message is still in your local mailqueue.

Woohoo! Progress! lol...

The messages are in the queue!


__somenumbers__ 3199 Sat Dec 23 16:22:27 MAILER-DAEMON
(connect to gmail.com[64.233.161.83]: Connection timed out)
username@gmail.com

What do I do now?

till
26th December 2006, 17:34
Do you get a smtp prompt when you run the following command on your server:

telnet gmail.com 25

To close the connection, type "quit".

BlueStream
26th December 2006, 18:09
Do you get a smtp prompt when you run the following command on your server:



To close the connection, type "quit".


interesting... it does not....

Trying 216.239.57.83...
telnet: connect to address 216.239.57.83: Connection timed out
Trying 64.233.171.83...
telnet: connect to address 64.233.171.83: Connection timed out
Trying 64.233.161.83...

falko
26th December 2006, 18:21
Try telnet gmail-smtp-in.l.google.com 25 instead.

BlueStream
27th December 2006, 02:13
Try telnet gmail-smtp-in.l.google.com 25 instead.

Now I do.

telnet gmail-smtp-in.l.google.com 25
Trying 64.233.163.114...
Connected to gmail-smtp-in.l.google.com (64.233.163.114).
Escape character is '^]'.
220 mx.google.com ESMTP 38si10209262nzf
ehlo localhost
250-mx.google.com at your service, [121.6.72.245]
250-SIZE 20971520
250-8BITMIME
250 ENHANCEDSTATUSCODES


What does it mean? I can only send emails to user@gmail-smtp-in.l.google.com?

till
27th December 2006, 12:56
What does it mean? I can only send emails to user@gmail-smtp-in.l.google.com?

No, you can send emails to user@google.com, gmail-smtp-in.l.google.com is just the Mail exchanger for gmail.com.

Is your server hosted on a DSL or cable line with dynamic IP address?

BlueStream
27th December 2006, 13:55
No, you can send emails to user@google.com, gmail-smtp-in.l.google.com is just the Mail exchanger for gmail.com.

Is your server hosted on a DSL or cable line with dynamic IP address?

It's ADSL and on a dynamic ip but I got the IP static and relevant DNS entries point to this IP, including the official domain, fusionstream.org which points directly to it.

falko
27th December 2006, 17:20
It's ADSL and on a dynamic ip
Then you're most likely blacklisted. Please check on http://www.mxtoolbox.com/blacklists.aspx

BlueStream
28th December 2006, 11:38
Then you're most likely blacklisted. Please check on http://www.mxtoolbox.com/blacklists.aspx

dammit.. i am... zzz

thx for help.. fyi.. using uebi still gives me all sorts of problems when sending mail even to myself but squirrelmail doesn't so... yea.. haha

thx