PDA

View Full Version : After setup...


Paul
10th October 2005, 15:44
I have install Sarge using instructions from http://www.howtoforge.com/perfect_setup_debian_sarge, everything was great! And when I try to edit file /etc/network/interfaces/, I've get the magic answer: Permission denied! When I try call other files, I haven't other answer. What's this problem? Root have full permissions default, but system say me "get out!" Why?
Serriously, how can I to continue my work?

till
10th October 2005, 16:12
Please try first the command "su" to go to root (and to make shure your really root).
Then use an editor like "vi" to edit the config file. It was reported taht some other editors (mostly KDE or Gnome GUI Editors) are giving permission denied errors on files even for the root user.

hilton
10th October 2005, 17:17
You could also just use pico.

It's much easier than vi but die-hard vi-ers will most probably argue with me.

Cheers
Hilton

Paul
11th October 2005, 09:16
Thanks, guys! I can do it using pico or nano. But I'm very yung linuxoid.:confused: Wait for more questions from me, OK?

Paul
11th October 2005, 15:13
If I use 2 network adaptors (eth0 for Internet, eth1 for LAN), should I type all IP-addresses etc. in file /etc/network/interfaces or create different files?

falko
11th October 2005, 15:57
If I use 2 network adaptors (eth0 for Internet, eth1 for LAN), should I type all IP-addresses etc. in file /etc/network/interfaces or create different files?
No, it's still /etc/network/interfaces. You have sections in it for lo and eth0, so simply create a new section for eth1. :)

Paul
11th October 2005, 16:35
And as gateway for eth1 sould I set the IP of eth0? (i will use this mashine as gateway LAN - Internet)

falko
11th October 2005, 19:54
And as gateway for eth1 sould I set the IP of eth0? (i will use this mashine as gateway LAN - Internet)
Hm, I think you have to do that with iptables rules. Maybe you should google for something like "Debian router howto" or so...
If you only need that box as a router, then I'd recommend that you install IPCop on it. http://www.ipcop.org/
Easy to install, and very secure. :)

Paul
12th October 2005, 08:36
Sorry, last question was incorrect. I found solution alrady ;)

Paul
12th October 2005, 18:37
I have edit /etc/network/interfaces so:

#The loopback network interface
auto lo
iface lo inet loopback

#The orimary network interface
auto eth0
iface eth0 inet static
address <external IP of my box>
netmask 255.255.255.240
network <IP of external network>
broadcast <broadcast IP of external network>
gateway <IP of provider's router>
# dns-* options are implemented by The resolconf package, if installed
dns-nameservers 127.0.0.1
dns-search <mydomain>
#The secondary network interface
auto eth1
iface eth1 inet static
address 192.1668.5.5
netmask 255.255.255.0
network 192.168.5.0

And where I restart networking, I get:

Setting up IP spoofing protection: rp_filter.
Reconfiguring network interfaces...ifup: interface lo already configured
eth0: link down
SIOCSIFADDR: no such device
eth1: ERROR while getting interface flags: No such device
SIOCSIFNETMASK: No such device
eth1: ERROR while getting interface flags: No such device
Failed to bring up eth1.
done.

Device is good, physical installed, by setup and lspci detected.
Maybe file is incorrect?

till
12th October 2005, 18:40
This is not a valid IP:

address 192.1668.5.5

falko
12th October 2005, 19:03
Can you try to re-boot your machine so that the correct network card driver can be loaded? Hopefully the driver is included in your kernel or available as a module (in the latter case you might have to include it in /etc/modules).

Paul
12th October 2005, 22:38
Setting up in expert26 mode has ask me for boot modules for 2 my ethernet cards. But this time setup was down because of unstable power. Next time I did setup with your instructions, in mode linux26, without this question. If I re-install the system one more time in expert26 mode, can I get correct driver? Just I'm not sure, that I can found and install this module manually quick, and expiriens-time is limited... :confused: