PDA

View Full Version : Internet connection sharing


fdawy
24th September 2005, 22:41
:(

http://www.w6w.net/upload2/24-09-2005/w6w_20050924150436931a5f9a.JPG
I must tried very very in this educational site in communion of the internet throughout the unix and i need to solve this ?????????!!!!!!!!!!!

i am trial from failure triales communion of the internet throughout another computer throughout the network

till
25th September 2005, 12:43
Most modern linux distributions like SuSE or Mandrake have graphical system management tools to enable internet connection sharing.

AngelDrago
25th September 2005, 18:42
I'm using Suse 9.3 and found it is very user friendly in this aspect but i'm using a Windows Base Network with about 100 pc's and 30 servers that i control just got tired of Windows XP i guess and needed a new challenge and linux is a challenge for me.

Peace
Angel

fdawy
26th September 2005, 12:24
how to set - set nat for linux

fdawy
26th September 2005, 12:26
Setting up a Linux PC to share its Internet connection

fdawy
27th September 2005, 21:57
:mad: the Internet connection sharing problem the set


"""" Let's get started then:

Edit /etc/sysconfig/network-scripts/ifcfg-eth0 - This is the main config file for the first (internet facing) interface.
It should read : (you can leave out anything on a line after #)

DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.1.2
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
ONBOOT=yes
MII_NOT_SUPPORTED=yes

Edit /etc/sysconfig/network-scripts/ifcfg-eth1 - This is the main config file for the second (LAN facing) interface.
It should read :

DEVICE=eth1
BOOTPROTO=static
IPADDR=192.168.3.1
NETMASK=255.255.255.0
NETWORK=192.168.3.0
BROADCAST=192.168.3.255
ONBOOT=yes
MII_NOT_SUPPORTED=yes
/etc/resolv.conf should contain the nameserver address(es) - put the address of your ISPs nameserver right at the top. eg:

nameserver 195.20.224.165You can have multiple nameserver xxx.xxx.xxx.xxx lines - the resolver will try them all in turn if one fails

The default gateway and your hostname go in /etc/sysconfig/network:

HOSTNAME=localhost
NETWORKING=yes
GATEWAY=192.168.1.1


We then need to set up packet forwarding:
Put the following command at the beginning of /etc/sysctl.conf

net.ipv4.ip_forward=1

Then 'turn off' the redirection to squid:
Install iptables - type "urpmi iptables" as root, or use the package manager in the start menu or mcc

Add the following code to the bottom of /etc/rc.d/rc.local.

iptables -t nat -D PREROUTING -i eth0 -j loc_dnatThis will delete a rule from your firewall - later, when you understand more, you can change shorewall and remove this line, but for now we'll keep it simple.


Reboot."""""""""


why problem