PDA

View Full Version : Need help with sites images dirs.


SkIRmiS
24th September 2005, 19:07
Hello,
need help with images. I have ~42 sites on ISPconfig system, but in some sites images are not showing. They are in www.domain.tld/Pictures/Foto/Foto/ dir. The error is
[Sat Sep 24 19:40:06 2005] [crit] [client 82.13*.*.1*] (13)Permission denied: /home/www/web42/web/img/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.s*im*.lt/index.php?page=ismok.

That to do?
What is the differens between PHP and PHP with checked PHP safe mod ?

Thanks
Skirmis

till
25th September 2005, 12:40
Hello,
need help with images. I have ~42 sites on ISPconfig system, but in some sites images are not showing. They are in www.domain.tld/Pictures/Foto/Foto/ dir. The error is
[Sat Sep 24 19:40:06 2005] [crit] [client 82.13*.*.1*] (13)Permission denied: /home/www/web42/web/img/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.s*im*.lt/index.php?page=ismok.

make the file /home/www/web42/web/img/.htaccess writable for the webserver user.


What is the differens between PHP and PHP with checked PHP safe mod ?

Safemode is secure mode for running PHP scripts, that enaables some restrictions like the path in which PHP is allowed to read file. Please have a look at the PHP documentation on www.php.net for a more detailed description of safemode.

SkIRmiS
26th September 2005, 10:31
[QUOTE=till]make the file /home/www/web42/web/img/.htaccess writable for the webserver user.

The same problema, I created empty file .htaccess and maded all permisions on this file for user.web24 also tried for www-data.www-data. The same problem with images. Can i disable .htaccess checking feature for a moment?

Thanks
Skirmis

till
26th September 2005, 10:49
You can try to put this line:

AllowOverride None

in the apache Directives field of the website.

SkIRmiS
26th September 2005, 10:58
The same, many sites cannot be displayed correctly:( Don't know what to do. The same sites on apache1.3.x were ok. Why the web server are checking for .htaccess file?

till
26th September 2005, 11:02
Normally images that where not displayed have nothing to do with .htaccess files. I posted the line for disbling them because you asked for it! .htaccess files are part of every normal apache installation. In the httpd.conf or the vhost you limit which directives can be overridden by .htaccess files.

SkIRmiS
26th September 2005, 11:08
Normally images that where not displayed have nothing to do with .htaccess files. I posted the line for disbling them because you asked for it! .htaccess files are part of every normal apache installation. In the httpd.conf or the vhost you limit which directives can be overridden by .htaccess files.

I'm not using .htaccess file, but some sites with default instaliation ISPconfig is not showing well. I didnt edited the http.conf. It is bye default of ISPconfig.

till
26th September 2005, 11:13
OK. Then you have to find out what the htaccess files want to change in the apache configuration and the enable these features with the AlloOverride directive.

If you are not shure waht to enable, you can try to set it to:

AllowOverride All

in the apache Directives field of the website (Then wait about a minute until ISPConfig has rewritten the apache config and restarted the httpd process). But "AllowOverride All" is not a safe solution and not recommendet! Use it only for testing!

SkIRmiS
26th September 2005, 11:30
Got error by ISPconfig:
# AllowOverride None # NOT SUPPORTED!
# AllowOverride All # NOT SUPPORTED!

till
26th September 2005, 11:36
Got error by ISPconfig:
# AllowOverride None # NOT SUPPORTED!
# AllowOverride All # NOT SUPPORTED!

Then you can edit it in your httpd.conf. Change:

<Directory /home/www/*/web>
Options +Includes +FollowSymlinks -Indexes
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all

<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

To:

<Directory /home/www/*/web>
Options +Includes +FollowSymlinks -Indexes
AllowOverride all
Order allow,deny
Allow from all

<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

SkIRmiS
26th September 2005, 13:51
Still the same problem:/
But i figured out and tried to chmod /img dir, not for user.webxx, but www-data.ww-data and everythings is working well. Maybe to add www-data to the same user group or something? Any suggestion? Thanks for taking time for me;)

Best wishes
Skirmis

SkIRmiS
26th September 2005, 15:24
Websites what are not owned by www-data.www-data are not normaly showed, missing some data, 4 example images. Where to search for resolution?

Thanks
Skirmis