PDA

View Full Version : Ubuntu 12.04 LTS Perfect Desktop GRUB Issue after Update


GCLumpkin
9th September 2013, 23:19
Good afternoon all,

I have a Dell laptop on which I have installed Ubuntu Linux 12.04 LTS. I followed the instruction in the "perfect desktop" guide and it has been great.

During periodic updates, I noticed that GRUB wanted to update and it was always unchecked so I let all the other updates install, thinking that I would research it before letting GRUB update. I did this for a very good reason, and that is because the GRUB update was for Linux Mint, not Ubuntu. I had some reservations.

The other day, during an update, GRUB was checked and the update proceeded before I could catch it. After that, the GRUB boot menu would come up after any reboot or power on and wait for me to explicitly choose the default kernel before going to the desktop. No automatic choice, not timeout. I also noticed the word 'Error" in the upper left hand of the screen just before the GRUB menu appears, but it was so fast, I couldn't see what it said.

I researched the issue and stumbled upon a tool called "Boot Repair" (http://www.howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/). I used it, but had to uncheck the option to re-install GRUB, or it would fail. After running it without the option to re-install GRUB, it did set the GRUB menu to automatically choose the default kernel after 10 seconds. You can see the countdown. The log for this tool can be found here: http://paste.ubuntu.com/6081553/.

I think the most significant part of the file is near the bottom and reads:

Recommended-Repair
This setting will purge (in order to fix packages fix executable) and reinstall the grub2 of sda1 into the MBR of sda.
Additional repair will be performed: unhide-bootmenu-10s


apt-get -y --force-yes update
Purge the GRUB of sda1
grub-pc available

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
grub-pc : Depends: grub-common but it is not going to be installed
Depends: grub2-common (= 1.99-12ubuntu5-1linuxmint1) but it is not going to be installed
Depends: grub-pc-bin (= 1.99-12ubuntu5-1linuxmint1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
DEBCHECK debNG, grub-pc
DEBCHECK debNG

Can someone tell me what I need to do to get this laptop to boot like it used to? Straight into Ubuntu without the GRUB menu displaying?

I still consider myself a novice at Linux. I've been using it off and on for about a decade or more, but there is still so much I don't understand and I don't want to hose up this laptop. It was hard enough just getting it to work with the Broadcom wireless card. :)

Thanks,
Greg

david_hitt@lionlike.com
10th September 2013, 17:00
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/647250

Bug in GRUB that they're working on to get resolved.

The following should work:

1. sudo gedit /etc/default/grub you need to change thsis

2. in the GRUB_HIDDEN_TIMEOUT_QUIET=false change to GRUB_HIDDEN_TIMEOUT_QUIET=true

3. save that file

4. type sudo update-grub

But because of the bug, it does not. The true flag has no effect.

GCLumpkin
11th September 2013, 01:47
So, you're saying that the version of GRUB that I upgraded to has a bug that ignores the "true" value and displays the menu and countdown anyway?